Closed Bug 1117085 Opened 5 years ago Closed 5 years ago

Simplify DoConcatStrings

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla37

People

(Reporter: jandem, Assigned: jandem)

References

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
Trying ConcatStrings<NoGC> first and then using the CanGC version if it fails is not necessary if JIT code just passes HandleStrings.
Attachment #8543260 - Flags: review?(terrence)
Comment on attachment 8543260 [details] [diff] [review]
Patch

Review of attachment 8543260 [details] [diff] [review]:
-----------------------------------------------------------------

Nice!
Attachment #8543260 - Flags: review?(terrence) → review+
Duplicate of this bug: 1116326
https://hg.mozilla.org/mozilla-central/rev/708869bcedae
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
You need to log in before you can comment on or make changes to this bug.