preference.value is null opening the font settings.

RESOLVED FIXED in Thunderbird 37.0

Status

defect
--
minor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mkmelin, Assigned: mkmelin)

Tracking

35 Branch
Thunderbird 37.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Opening Preferences | Display | Formatting | Advanced gives me

Error: preference.value is null
Source File: chrome://messenger/content/preferences/fonts.js
Line: 88

... with little other visible problems.
Attachment #8543265 - Flags: review?(bwinton)
Comment on attachment 8543265 [details] [diff] [review]
bugXXX_preference_is_null_fonts.patch

Review of attachment 8543265 [details] [diff] [review]:
-----------------------------------------------------------------

This will certainly fix the problem, but I'm curious why preference exists, but preference.value is null?
Attachment #8543265 - Flags: review?(bwinton) → review+
The cause is the element: null values here: http://mxr.mozilla.org/comm-central/source/mail/components/preferences/fonts.js#26

I don't really know what the meaning of those are, and cvs archeology says it's been like this forever in tb.
https://hg.mozilla.org/comm-central/rev/d5b310aab115 -> FIXED
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 37.0
You need to log in before you can comment on or make changes to this bug.