#include CompositorChild.h to fix non-unified build bustage

RESOLVED DUPLICATE of bug 1112332

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1112332
4 years ago
4 years ago

People

(Reporter: cpeterson, Assigned: cpeterson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 8543318 [details] [diff] [review]
include-CompositorChild-header.patch

Non-unified build bustage from bug 1112332:

 gfx/layers/client/ClientTiledPaintedLayer.cpp:193:18: error: member access into incomplete type 'mozilla::layers::CompositorChild'
    if (!compositor->LookupCompositorFrameMetrics(aParentMetrics.GetScrollId(),
                   ^
  ../../dist/include/nsIWidget.h:48:7: note: forward declaration of 'mozilla::layers::CompositorChild'
  class CompositorChild;
        ^
Attachment #8543318 - Flags: review?(bgirard)

Updated

4 years ago
Attachment #8543318 - Flags: review?(bgirard) → review+
Folded into bug 1112332.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1112332
You need to log in before you can comment on or make changes to this bug.