Mousing over a link is now extremely slow (:hover is slow)

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
17 years ago
5 years ago

People

(Reporter: hwaara, Assigned: roc)

Tracking

({perf, regression})

Trunk
x86
All
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mousing over links seems to have slowed down a lot lately.

To reproduce:

1. Mouse-over a list of links. You'll notice that the statusbar has a hard time
updating with all the info.

2. Drag the cursor (as in selecting text) over a paragraph that has a link in
it. When the cursor is above the link, the selection will "lag" before it
continues...

This is quite hard to explain. But by trying one of the two above testcases,
you'll notice this regression.

Build: 2001-11-23, Windows 98.
(Reporter)

Comment 1

17 years ago
*** Bug 111764 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

17 years ago
This is a bad and very visible performance regression.

dbaron, any idea what the slowdown could be? Roc, is this due to your
checkin(s)? (wild guess.)
Keywords: regression
Summary: Mousing over a link or dragging over a link is now extremely slow → Mousing over a link is now extremely slow (:hover is slow)
This is almost definitely due to roc's changes, which were causing things like
:hover to repaint the entire page (before he backed them out).
Assignee: attinasi → roc+moz
Component: Layout → Views

Updated

17 years ago
Keywords: perf
(Reporter)

Comment 4

17 years ago
This is still much slower than usual in today's CVS trunk. :-(
(Reporter)

Comment 5

17 years ago
A good testcase:  go to http://www.w3.org/TR/SVG/ and mouse fairly slowly over
the list of links... You'll definitely notice the problem.

The :hover effect will not be applied unless you stop moving for a little while.
Is it slower than it was in a build from a few weeks ago?  (It seems pretty
quick to me.)
(Reporter)

Comment 7

17 years ago
Yes, it's much slower.  

I will download yet another nightly build and see if the problem is reproducible
there.
(Reporter)

Comment 8

17 years ago
It was confusing that the nightly the day _after_ roc had been backed out was
still showing the slow, bad behaviour. In this new nightly I just downloaded,
things are back to normal. Phew!
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.