Closed Bug 1117215 Opened 5 years ago Closed 5 years ago

In Compose (Write), Selected incomplete To: entries from Address Book are overwritten by first entry in list before Send

Categories

(Thunderbird :: Message Compose Window, defect)

31 Branch
x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1107844

People

(Reporter: don.b.anderson, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36

Steps to reproduce:

In 31.3.0 Opened new 'Write' window and started entering 'To:' address.
Suggestions from Address Book are listed, as first addressee characters are entered and before address completion.
Selected 2nd or 3rd suggested addressee before completing whole address.
Selected addressee is copied to 'To:' list
Pressed 'Enter' to create a further 'To:' entry - new blank line created BUT the address in the first 'To;' line gets replaced by the 1st suggested entry peovided from the Address Book.



Actual results:

Pressed 'Enter' to create a further 'To:' entry - new blank line created BUT the address in the first 'To;' line gets replaced by the 1st suggested entry peovided from the Address Book.
Unless spotted and corrected, the email is sent to the wrong addressee


Expected results:

The original addressee selected from the list, as suggested from Address Book, should have been retained in the 'To:' list.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1107844
You need to log in before you can comment on or make changes to this bug.