If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Upgrade monolith ES to 1.0+

RESOLVED FIXED

Status

Cloud Services
Operations: Marketplace
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: robhudson, Assigned: jason)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I started updating the monolith code from facets to aggregations thinking the monolith elasticsearch instances were 1.0+ already and am now getting:

Parse Failure [No parser for element [aggregations]]];

Which led me to check what version of Elasticsearch we're on for Monolith and I discovered we're on 0.90.5.

Let's get on one of the latest 1.x branches, please.
(Reporter)

Updated

3 years ago
Blocks: 1116898
(Assignee)

Updated

3 years ago
Assignee: nobody → jthomas
(Assignee)

Comment 1

3 years ago
I've updated -dev and stage to point to the marketplace stage elasticsearch cluster which is currently on 1.2.x. I will be upgrading this instance to 1.3.x as part of bug 1107319. 

Production will require a brief outage, and possibly reindex. According to elasticsearch we should be to go from 0.90.x to 1.x.
(Assignee)

Comment 2

3 years ago
monolith prod elasticsearch cluster has been upgraded to 1.3.7.  The indices recovered without issue so I did not do a reindex. Let me know if you have any issues.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.