Closed Bug 11173 Opened 21 years ago Closed 21 years ago

Crash in javascript trying to find appversion

Categories

(Core :: JavaScript Engine, defect, P3, critical)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: bratell, Assigned: brendan)

References

()

Details

Overview Description:
Apprunner crashes when visiting http://www.lysator.liu.se/~bratell/mainmenu.html
in some JavaScript-related part of mozilla. The stack trace is:

nsServiceManagerImpl::GetService(nsServiceManagerImpl * const 0x00a31780, const
nsID & {...}, const nsID & {...}, nsISupports * * 0x0012ee80,
nsIShutdownListener * 0x00000000) line 229 + 23 bytes
nsServiceManager::GetService(const nsID & {...}, const nsID & {...}, nsISupports
* * 0x0012ee80, nsIShutdownListener * 0x00000000) line 448
nsService::nsService(const nsID & {...}, const nsID & {...}, unsigned int *
0x0012ee6c) line 291 + 23 bytes
NavigatorImpl::GetAppVersion(NavigatorImpl * const 0x0a6d6674, nsString & {...})
line 3137 + 23 bytes
GetNavigatorProperty(JSContext * 0x0a2aac20, JSObject * 0x00cddff8, long -5,
long * 0x0012f754) line 123 + 19 bytes
js_GetProperty(JSContext * 0x0a2aac20, JSObject * 0x00cddff8, long 174934096,
long * 0x0012f754) line 1700 + 72 bytes
js_Interpret(JSContext * 0x0a2aac20, long * 0x0012f8c4) line 2184 + 977 bytes
js_Execute(JSContext * 0x0a2aac20, JSObject * 0x00cdd348, JSScript * 0x0a6d68d0,
JSFunction * 0x00000000, JSStackFrame * 0x00000000, int 0, long * 0x0012f8c4)
line 827 + 13 bytes
JS_EvaluateUCScriptForPrincipals(JSContext * 0x0a2aac20, JSObject * 0x00cdd348,
JSPrincipals * 0x0a6d4aa0, const unsigned short * 0x00ced148, unsigned int 1053,
const char * 0x0a6d4c20, unsigned int 10, long * 0x0012f8c4) line 2596 + 27
bytes
nsJSContext::EvaluateString(nsJSContext * const 0x0a2aad90, const nsString &
{...}, const char * 0x0a6d4c20, unsigned int 10, nsString & {...}, int *
0x0012f8ec) line 155 + 66 bytes
HTMLContentSink::EvaluateScript(nsString & {...}, int 10) line 3057
HTMLContentSink::ProcessSCRIPTTag(const nsIParserNode & {...}) line 3224
HTMLContentSink::AddLeaf(HTMLContentSink * const 0x0a2a9b10, const nsIParserNode
& {...}) line 2147 + 12 bytes
CNavDTD::AddLeaf(const nsIParserNode & {...}) line 2668 + 22 bytes
CNavDTD::AddHeadLeaf(nsIParserNode & {...}) line 2700 + 14 bytes
CNavDTD::HandleStartToken(CToken * 0x09bad2f0) line 1308 + 12 bytes
NavDispatchTokenHandler(CToken * 0x09bad2f0, nsIDTD * 0x0a6d1080) line 242 + 12
bytes
CTokenHandler::operator()(CToken * 0x09bad2f0, nsIDTD * 0x0a6d1080) line 80 + 14
bytes
CNavDTD::HandleToken(CNavDTD * const 0x0a6d1080, CToken * 0x09bafa90, nsIParser
* 0x0a2a9d50) line 732 + 18 bytes
CNavDTD::BuildModel(CNavDTD * const 0x0a6d1080, nsIParser * 0x0a2a9d50,
nsITokenizer * 0x0a6d2820, nsITokenObserver * 0x00000000, nsIContentSink *
0x0a2a9b10) line 552 + 20 bytes
nsParser::BuildModel() line 941 + 34 bytes
nsParser::ResumeParse(nsIDTD * 0x00000000, int 0) line 886 + 11 bytes
nsParser::OnDataAvailable(nsParser * const 0x0a2a9d54, nsIChannel * 0x09dcba80,
nsISupports * 0x00000000, nsIInputStream * 0x0a279050, unsigned int 0, unsigned
int 2745) line 1168 + 19 bytes
nsDocumentBindInfo::OnDataAvailable(nsDocumentBindInfo * const 0x0a26d200,
nsIChannel * 0x09dcba80, nsISupports * 0x00000000, nsIInputStream * 0x0a279050,
unsigned int 0, unsigned int 2745) line 2046 + 32 bytes
nsHTTPResponseListener::OnDataAvailable(nsHTTPResponseListener * const
0x0a279090, nsIChannel * 0x09dcb570, nsISupports * 0x09dcba80, nsIInputStream *
0x0a279050, unsigned int 0, unsigned int 2745) line 162 + 47 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x0a27a2b0)
line 350
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x0a27a2b4) line 149 + 12 bytes
PL_HandleEvent(PLEvent * 0x0a27a2b4) line 509 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00af50b0) line 470 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x021303f4, unsigned int 49385, unsigned int 0,
long 11489456) line 932 + 9 bytes
USER32! 77e71820()
00af50b0()

Steps to Reproduce:
1) run "apprunner http://www.lysator.liu.se/~bratell/mainmenu.html"

Actual Results:
Crashes with "illegal memory 0xdddddddd"

Expected Results:
View the page and not crash

Build Date & Platform Bug Found:
Windows NT SP5, Visual C++ 6 SP3 Debug build

Additional Builds and Platforms Tested On:
None

Additional Information:
None
Summary: Crash in javascript
Summary: Crash in javascript → Crash in javascript trying to find appversion
*** Bug 11174 has been marked as a duplicate of this bug. ***
The only difference with 11174 is that there they try to get the appname.
Assignee: mccabe → brendan
Reassigning to brendan@mozilla.org as possible cvs blamee for
http://lxr.mozilla.org/seamonkey/source/dom/src/base/nsGlobalWindow.cpp#3140
from the stack trace.
Status: NEW → ASSIGNED
mccabe threw me a hot potato, but I ducked so dp (service manager god) could
catch it.  I'm gonna try to debug it, real fast, before reassigning.  Dp, stop
me if you've seen this one.

/be
This so works for me in my build pulled on Monday.  Let me update and try again.

/be
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Now it works for me too so I guess the bug was fixed by. I'll mark it as
such.
I fixed this one Tue morning. There was an extra release in AppVersion and
friends. This was showing up all over the place. :-)
Status: RESOLVED → VERIFIED
great. 8/31/99 --cmb.
You need to log in before you can comment on or make changes to this bug.