Closed Bug 1117354 Opened 5 years ago Closed 5 years ago

FF Developer 36 breakpoints unsuable. Somewhat predictable.

Categories

(DevTools :: Debugger, defect)

36 Branch
x86
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1122064

People

(Reporter: optout1, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150103004010

Steps to reproduce:

set breakpoints - no break. http://stroudvoices.co.uk/c/m.htm is the page that does this.
http://cresby.com - FF 36 can't display a js file - stoppress.js .


Actual results:

 no break.  after F5, breakpoints can (usually) break. Release breakpoint - breakpoint re-instated - no break on any new breakpoint until F5.


Expected results:

break
There is a timer and that (in FF 34 Portable) will break unconditionally whenever set.
It may be (speculatively) I have chosen  variable names that clash. I can list my variables but which will clash? I could uninstall and re-install. Win7 Prof, ssd HDD
Whiteboard: F5
Component: Untriaged → Developer Tools: Debugger
Whiteboard: F5
Same issue here.   

This WORKS:
Firefox (standard edition) + Firebug, set a breakpoint in slp.js on line 1151 (currently this may change) in this.createSidebar on the last div.id assignment in the method.    I am trying to view the content of the div variable on each iteration through the loop.

This DOES NOT work:
Same setup as above, but use Firefox Developer edition.  Open the debugger and set a breakpoint on slp.js on the same exact line.   The breakpoint is never reached.


Expected Result:
Mozilla Firefox Developer Edition should behave like Firefox + Firebug.   Break on the breakpoint as each element of the JSONP response is processed through the createSidebar method.

In the current state the Debugger in Mozilla Developer Edition is useless.



I am the author of the slp.js script, part of the WordPress Store Locator Plus plugin.   I can provide any assistance necessary on the use of the system to reproduce the issue on a regular basis via a Vagrant box setup.
(In reply to lance from comment #1)
> Same issue here.   

URL to reproduce: http://www.charlestonsw.com/support/documentation/store-locator-plus/slp-customers/
Not sure if this is related but I did attempt to remotely debug a Samsung S3 Mini, after installing the ADB DLL as per instructions. Remote connection failed.
I have now uninstalled FireFox Developer 36, as it serves no purpose over FF 34 (for me).
Critical bugs like this and not a single response in a month? This kind of thing is what drives people to chrome.
James, can you take a look at these issues and see if they are related to recent changes?
Flags: needinfo?(jlong)
Yes, this was exactly bug  that got fixed late January. I reproduced it in an older build but it is fixed in a newer one. It's been fixed for about 2 weeks. Sorry we didn't see this bug to mark it as duplicate!
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jlong)
Resolution: --- → DUPLICATE
Duplicate of bug: 1122064
Oops, sorry I cut the bug number out. It was bug 1122064.
Many thanks, indeed it has been fixed in nightly.
(In reply to simonzack from comment #8)
> Many thanks, indeed it has been fixed in nightly.

It actually should be uplifted all the way through to beta, if it was still happening there. So it shouldn't be broken anywhere.
The latest beta appears to have fixed it too, but the breakpoint doesn't work anymore after refresh, it could be caused by Bug 1057031, I'm getting the same "info is null" error.
(In reply to simonzack from comment #10)
> The latest beta appears to have fixed it too, but the breakpoint doesn't
> work anymore after refresh, it could be caused by Bug 1057031, I'm getting
> the same "info is null" error.

Does it still work in nightly though? The "info is null" error is probably innocuous (usually is), and in nightly/aurora there's some stuff in there to make sure scripts don't get GCed.
(In reply to James Long (:jlongster) from comment #11)
> Does it still work in nightly though?

I've just tried the latest nightly. The breakpoint refresh problem is still there, though the "info is null" has disappeared.

It's on http://www.charlestonsw.com/support/documentation/store-locator-plus/slp-customers/, slp.js, line 1058, btw.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.