Last Comment Bug 1117541 - Fix and run xpcshell tests for the provider
: Fix and run xpcshell tests for the provider
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Provider: GData (show other bugs)
: Trunk
: All All
-- normal (vote)
: 4.0.0.1
Assigned To: Philipp Kewisch [:Fallen]
:
:
Mentors:
Depends on: 1101175 1110881 1116227 1117339 1117340 1117341 1117540 1124152 1124154
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-04 08:24 PST by Philipp Kewisch [:Fallen]
Modified: 2015-01-27 16:20 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix - v1 (4.04 KB, patch)
2015-01-04 08:41 PST, Philipp Kewisch [:Fallen]
mohit.kanwal: review+
Details | Diff | Splinter Review
Fix - v2 (8.09 KB, patch)
2015-01-21 04:14 PST, Philipp Kewisch [:Fallen]
mohit.kanwal: review+
Details | Diff | Splinter Review

Description User image Philipp Kewisch [:Fallen] 2015-01-04 08:24:30 PST
The test are skipped currently since there are a few minor errors that I didn't have time to fix. Mostly about variables declared twice and a small change needed after the throttling additions.
Comment 1 User image Philipp Kewisch [:Fallen] 2015-01-04 08:41:59 PST
Created attachment 8543668 [details] [diff] [review]
Fix - v1

https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=e48ab8fbfe94

Lets hope it works :)
Comment 2 User image Mohit Kanwal [:redDragon] 2015-01-04 21:04:32 PST
It almost worked :) looks like [getAllMeta(calendar)...][1] is returning only 1 item. Is it because of the same recurrence Id?

[1]: https://hg.mozilla.org/try-comm-central/file/befa4eabce68/calendar/test/unit/test_gdata_provider.js#l1153
Comment 3 User image Philipp Kewisch [:Fallen] 2015-01-18 12:41:54 PST
recurringEventId is the id of the orginal event, so it should be fine. I kind of wonder why it passed on opt and failed on debug and only happens on linux. I'm doing another try run now just for the hell of it, then I might do another few with more debug messages.
Comment 4 User image Philipp Kewisch [:Fallen] 2015-01-18 12:57:17 PST
Oh wait, I see what you mean. I missed to change the ID of the second exception, it is also go6ijb0b46hlpbu4eeu92njevo_20060610T160000Z. I've changed this now and have started a second try run:

https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=75ffffc78aea

I had to disable the ical.js tests, because they are failing horribly. This needs to be fixed before pushing of course.
Comment 5 User image Mohit Kanwal [:redDragon] 2015-01-18 20:33:31 PST
Comment on attachment 8543668 [details] [diff] [review]
Fix - v1

Review of attachment 8543668 [details] [diff] [review]:
-----------------------------------------------------------------

Yep Looks like now it works
Comment 6 User image Philipp Kewisch [:Fallen] 2015-01-18 23:13:38 PST
Actually, I'm still seeing it on Linux debug:

TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_gdata_provider.js | test_metadata_recurring - [test_metadata_recurring : 1153] 1 == 3
Comment 7 User image Philipp Kewisch [:Fallen] 2015-01-21 04:14:39 PST
Created attachment 8552416 [details] [diff] [review]
Fix - v2

Here is an updated patch. It definitely passes on Linux:

https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=d7c558d69ccd

I'm running a full try run after a few more small changes. I'll also have to file bugs for a few more patches so this one should be pushed last.

https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=b1445f13fa1c
Comment 8 User image Philipp Kewisch [:Fallen] 2015-01-21 07:03:36 PST
Nice, tests pass. The failures are not caused by this patch.
Comment 9 User image Mohit Kanwal [:redDragon] 2015-01-21 08:52:39 PST
Comment on attachment 8552416 [details] [diff] [review]
Fix - v2

Review of attachment 8552416 [details] [diff] [review]:
-----------------------------------------------------------------

All Good here!
Comment 10 User image Philipp Kewisch [:Fallen] 2015-01-27 16:20:53 PST
comm-central changeset 29b2f7fd82ac

Note You need to log in before you can comment on or make changes to this bug.