Closed Bug 11176 Opened 21 years ago Closed 21 years ago

[PP]New Blank Window from browser crashes every other time

Categories

(Core :: DOM: Editor, defect, P2, major)

Other
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 10774

People

(Reporter: sujay, Assigned: akkzilla)

Details

using 8/3 build of linux apprunner

1) launch apprunner
2) pull-down File | New | Blank Window

watch it come up the first time.

3) then close that new blank window
4) then repeat step 2) again

crash.

I can reproduce this every time...but its every other time that it happens..

linux only.
Assignee: buster → akkana
Severity: normal → major
Priority: P3 → P2
akkana, can you get a stack on the crash and reassign to the right person?
thanks.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
It only happens when we do File->Close, not when we close from the windowmgr
close button.  The stack is pretty messed up (memory corruption?) but here it
is:

#0  0x4910ec13 in ?? ()
#1  0x4911f18f in ?? ()
#2  0x49142061 in ?? ()
#3  0x4910e6a2 in ?? ()
#4  0x4911f6f6 in ?? ()
#5  0x491420b2 in ?? ()
#6  0x40040f90 in nsCOMPtr<nsISupports>::~nsCOMPtr (this=0x8a8a254,
    __in_chrg=2) at ../../../dist/include/nsCOMPtr.h:473
#7  0x4915b390 in ?? ()
#8  0x4915b48e in ?? ()
#9  0x490879aa in ?? ()
#10 0x49086f2c in ?? ()
#11 0x4908700f in ?? ()
#12 0x4908c48c in ?? ()
#13 0x40335a94 in js_FinalizeObject (cx=0x8b189c0, obj=0x8967a40)
    at jsobj.c:1259
#14 0x40314cdf in js_GC (cx=0x8b189c0) at jsgc.c:832
#15 0x4031456c in js_ForceGC (cx=0x8b189c0) at jsgc.c:615
#16 0x402ed73f in JS_GC (cx=0x8b189c0) at jsapi.c:1073
#17 0x4022584d in nsJSContext::GC (this=0x8b189a0) at nsJSEnvironment.cpp:349
#18 0x4017a2a6 in nsWebShell::Embed (this=0x8b15bd0, aContentViewer=0x8904d10,
    aCommand=0x8b8acd8 "view", aExtraInfo=0x0) at nsWebShell.cpp:899
#19 0x401774c5 in nsDocumentBindInfo::OnStartRequest (this=0x8b8de00,
    channel=0x8b8e028, ctxt=0x0) at nsDocLoader.cpp:1942
#20 0x409ec9eb in ?? ()
#21 0x409ec593 in ?? ()
#22 0x4040b23f in PL_HandleEvent (self=0x8b8e298) at plevent.c:509
#23 0x4040b155 in PL_ProcessPendingEvents (self=0x80ad638) at plevent.c:470
#24 0x400a88f5 in nsEventQueueImpl::ProcessPendingEvents (this=0x80a2b50)
    at nsEventQueue.cpp:118
#25 0x400f65a6 in event_processor_callback (data=0x80a2b50, source=9,
    condition=GDK_INPUT_READ) at nsAppShell.cpp:149
#26 0x405b05d8 in gdk_io_invoke ()
#27 0x1 in ?? ()
#28 0x535604ec in ?? ()

There's a known problem involving the editor crashing on exit; I'm going to take
a guess that this is the same issue, and tenatively mark it a dup of 10774.
Cc'ing nisheeth since this might be another case of webshell leakage.



*** This bug has been marked as a duplicate of 10774 ***
Status: RESOLVED → VERIFIED
verified in 8/5 build.
setting to an approximate milestone so it can be off of the no TFV list
Target Milestone: --- → M8
You need to log in before you can comment on or make changes to this bug.