Closed Bug 1117681 Opened 5 years ago Closed 5 years ago

widget/android/nsWindow.cpp:1635:10: error: reference to 'AKEYCODE_CTRL_RIGHT' is ambiguous

Categories

(Core :: Widget: Android, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla37

People

(Reporter: m_kato, Assigned: m_kato)

References

Details

Attachments

(1 file, 1 obsolete file)

When I set --with-android-version=14, the following build errors occur.


/home/makoto/Development/hg.mozilla.org/mobile/widget/android/nsWindow.cpp:1635:10: error: reference to 'AKEYCODE_CTRL_RIGHT' is ambiguous
     case AKEYCODE_CTRL_RIGHT:
          ^
In file included from /home/makoto/bin/android-ndk-r10d/platforms/android-14/arch-arm/usr/include/android/input.h:45:0,
                 from /home/makoto/Development/hg.mozilla.org/mobile/widget/android/AndroidJavaWrappers.h:10,
                 from /home/makoto/Development/hg.mozilla.org/mobile/widget/android/nsWindow.h:13,
                 from /home/makoto/Development/hg.mozilla.org/mobile/widget/android/nsWindow.cpp:28:
/home/makoto/bin/android-ndk-r10d/platforms/android-14/arch-arm/usr/include/android/keycodes.h:160:5: note: candidates are: <anonymous enum> AKEYCODE_CTRL_RIGHT
     AKEYCODE_CTRL_RIGHT      = 114,
     ^
In file included from /home/makoto/Development/hg.mozilla.org/mobile/widget/android/nsWindow.h:13:0,
                 from /home/makoto/Development/hg.mozilla.org/mobile/widget/android/nsWindow.cpp:28:
/home/makoto/Development/hg.mozilla.org/mobile/widget/android/AndroidJavaWrappers.h:239:5: note:                 mozilla::<anonymous enum> AKEYCODE_CTRL_RIGHT
     AKEYCODE_CTRL_RIGHT         = 114,
     ^
OS: Linux → Android
Hardware: x86_64 → All
Attached patch Fix (obsolete) — Splinter Review
Assignee: nobody → m_kato
Attached patch fixSplinter Review
Use __ANDROID_API__ to fix conflict
Attachment #8543856 - Attachment is obsolete: true
Attachment #8543861 - Flags: review?(snorp)
Attachment #8543861 - Flags: review?(snorp) → review+
https://hg.mozilla.org/mozilla-central/rev/02de139764d9
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Duplicate of this bug: 1091987
You need to log in before you can comment on or make changes to this bug.