[Flame][Bluetooth]The name of transferred file can't be displayed.

VERIFIED FIXED in 2.2 S3 (9jan)

Status

defect
VERIFIED FIXED
5 years ago
Last year

People

(Reporter: liuke, Assigned: zbraniecki)

Tracking

({regression})

unspecified
2.2 S3 (9jan)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified)

Details

Attachments

(6 attachments)

Posted file logcat_1627.txt
[1.Description]:
[Flame][v2.2][Bluetooth]The transfer file name can't be displayed after you transfer a file completely.
Found time:16:27
See attachment:1627.mp4 and logcat_1627.txt

[2.Testing Steps]: 
1.Launch Gallery/Music/video.
2.Select a image to share use BT.
3.After transfer completes, slide down the Notification.

Note: This bug still exist in received file.

[3.Expected Result]: 
3.The file name should be displayed in prompt bar.

[4.Actual Result]: 
3.The image name can't be displayed in transfer prompt bar.

[5.Reproduction build]: 
Flame2.2
Gaia-Rev        c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/55f3224d7513
Build-ID        20150104010206
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150104.043402
FW-Date         Sun Jan  4 04:34:12 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free Test
Reporter

Comment 1

5 years ago
Posted video 1627.MP4
Hi Jamin, I remember this is the current design, right?
Flags: needinfo?(jaliu)
The symptom disappears with attached gaia patch. ni? Gaia dev Ian to confirm whether it's a bug or by design.
Flags: needinfo?(jaliu) → needinfo?(iliu)

Updated

5 years ago
Component: Bluetooth → Gaia::Bluetooth File Transfer
This is a regression issue from bug 1095109.

https://github.com/mozilla-b2g/gaia/blame/master/apps/system/js/bluetooth_transfer.js#L491

Zibi, The file name was assigned with `'bodyL10n': nData.bodyL10n,`. It always shows 'unknown file'.    Could you please have follow up patch for fixing the issue? Thanks.
Blocks: 1095109
blocking-b2g: --- → 2.2?
Flags: needinfo?(iliu) → needinfo?(gandalf)
Keywords: regression
absolutely, taking.
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
Flags: needinfo?(gandalf)
Posted file pull request
patch
Comment on attachment 8544376 [details] [review]
pull request

Hi Ben,

Can you review my patch?
Attachment #8544376 - Flags: review?(btian)
Comment on attachment 8544376 [details] [review]
pull request

Redirect r? to Ian for gaia change.
Attachment #8544376 - Flags: review?(btian) → review?(iliu)

Comment 9

5 years ago
Triage:regression, blocking
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8544376 [details] [review]
pull request

Thanks for Zibi's help. The patch is working for me. r+
Attachment #8544376 - Flags: review?(iliu) → review+
Commit: https://github.com/zbraniecki/gaia/commit/fe13e42f9072654fa5400ffde52dc26b546ac9ee
Merge: https://github.com/mozilla-b2g/gaia/commit/710359e959d397a4cb2231ae7ec554140ba80e76

Apologies for the regression
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S3 (9jan)

Comment 12

5 years ago
Posted image screenshot.png
This issue has been verified successfully on Flame 2.2
See attachment:video.MP4 and screenshot.png

Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150114002502
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150114.040029
FW-Date         Wed Jan 14 04:00:40 EST 2015
Bootloader      L1TC000118D0

Comment 13

5 years ago
Posted video video.MP4

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.