Closed Bug 1117699 Opened 10 years ago Closed 9 years ago

[Stingray][Home] Allow user to move cards into folder

Categories

(Firefox OS Graveyard :: Gaia::TV::Home, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rexboy, Assigned: yifan)

References

Details

(Whiteboard: [ft:conndevices])

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1105982 +++

In edit mode, allow user to move cards from main list into folder.
This is a follow-up bug from bug 1105982.
Blocks: 1149447
No longer blocks: 1074084
Component: Gaia → Gaia::TV::Home
Assignee: nobody → yliao
Blocks: 1156143
Blocks: 1158665
Attached file pull request
* Rename swap card queue to move queue.
* Fix delete card and add new folder bug caused by _concealPanel causing cardScrollable focus null.
* Add hover over folder functionality.
* Finish folder viewer layout and hover animations in edit mode.
* Implement add to folder functionality.
* Implement card swapping in folder list.
Attachment #8599123 - Flags: review?(rexboy)
Comment on attachment 8599123 [details] [review]
pull request

Sorry I took some time to go through the review.
Most of my comments are suggestions and typo, but I have to cancel since it causes a regression that you can open an app on hovering, then things just goes wrong.
Please repair it and send review to me again (Modifications on another patch if possible). Thanks!
Attachment #8599123 - Flags: review?(rexboy)
Comment on attachment 8600691 [details] [review]
[gaia] begeeben:1117699_allow_user_to_move > mozilla-b2g:master

Thanks! Here's the new patch to be reviewed. Most comments in Github have been fixed including:

* move hoveringItem and hoveredItem to XScrollable
* TODO comments and styles
* bugs pressing left/right/down after inserting a card

except:

* CardManager.findContainingFolder
* Folder events delegation
* this.edit.isFolderReady hack

Would like to clarify these with you in person.
Attachment #8600691 - Flags: review?(rexboy)
Comment on attachment 8600691 [details] [review]
[gaia] begeeben:1117699_allow_user_to_move > mozilla-b2g:master

r=me with some comments there. Please take a look before landing.
Thanks a lot!
Attachment #8600691 - Flags: review?(rexboy) → review+
Thanks! Fixed & merged into master.

https://github.com/mozilla-b2g/gaia/pull/29845
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-cherry-pick]
Whiteboard: [ft:conndevices][partner-cherry-pick] → [ft:conndevices]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: