netscape.com - Netscape radio not working on Linux (Realplayer not scriptable)

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Menashay, Unassigned)

Tracking

Details

(Whiteboard: [plugin], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011012
BuildID:    2001112217

Netscape radio produces Java Script errors and thus does not function.

Reproducible: Always
Steps to Reproduce:
Enter the site http://radio.netscape.com/radio/radiosell.html
and launch the radio.  Assuming you do have the real player plugin installed you
should hear the test music.  Now try selecting a channel.  Radio does not work.
Open the window JavaScript Console and you see the following error

Error: parent.frames[1].document.thePlugin.SetSource is not a function
Source File: http://spinner.netscape.com/playchannel.js
Line: 7

Woring with Sun Java
Java(TM) Plug-in 1.4.0-beta-b65
/usr/local/j2sdk1.4.0/jre/plugin/i386/ns600/libjavaplugin_oji140.so

Real Player 8.0 for Linux
Mandrake 8.1, KDE 2.2.2



Actual Results:  Cannot hear the radio despite test music working, ie., the
realplayer is recognised by Mozilla and does work.

Expected Results:  Should hear Netscape Radio.

Radio does work with Netscape 4.7x

Comment 1

16 years ago
*** Bug 105861 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
resolving as new. I can't hear a thing there either.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Reassigning to Plug-ins. 

I remember that at one point, Real did not have an XPConnect plug-in,
only a LiveConnect one, which is no longer supported by Mozilla.

Could this be another dupe of bug 59935, then?
Or is Real Player 8.0 for Linux scripted via XPConnect now? 
Assignee: rogerl → av
Component: Javascript Engine → Plug-ins
QA Contact: pschwartau → shrir

Comment 4

16 years ago
serge, do you know if there is xpcom version for Linux available?

Comment 5

16 years ago
I have redhat7.0 and realplayer7.0 plugin which is not xpconnect enable,
I do not have real8.0 plugin to test, but according of this bug most likely it
is not xpcom yet, at least I'm getting the sane js error with 7.0

Comment 6

16 years ago
--- Mass reassigning Unix bugs to serge ---
Assignee: av → serge

Comment 7

16 years ago
I think that the reason of the bug is the same as for
bug #105124: java callbacks in ns4xPlugin.cpp are not implemented.
RealPlayer8 plugin invokes method GetJavaPeer and gets NULL.
I found out (by means of 'ps' program)
 that realplayer begins to work but it doesn't
open the file specified in 'src' parameter. I'm not sure
that this dup of #105124 but the reasons of both these bugs look
very similarly.

Comment 8

16 years ago
I think this is a dup of bug 59935 but we may need some help from evangelism.
Assignee: serge → aruner
Component: Plug-ins → Plugins
Product: Browser → Tech Evangelism
QA Contact: shrir → mgalli
Summary: Netscape radio not working → Netscape radio not working on Linux (Realplayer not scriptable)
Version: other → unspecified

Updated

16 years ago
Keywords: evang500
Summary: Netscape radio not working on Linux (Realplayer not scriptable) → netscape.com - Netscape radio not working on Linux (Realplayer not scriptable)

Updated

16 years ago
Blocks: 118291

Comment 9

15 years ago
*** Bug 181642 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
As a complement,

In Mozilla 1.1 in Conectiva Linux 8.0: Radio@Netscape opens about 4 Real Player
windows and in all but the first window I get a message like this:

 .. Invalid URL protocol. Valid protocols are .......http://...
!
/home/Adelson/tmp/.....
in the first window nothing happens => no music
In Netscape 7.0 it seems that no error message comes but nothing happens too
(Red Hat 7.2).
In Netscape 4.79 about two or three windows are open with a message like in
Mozilla 1.1 but the first window plays Radio@Netscape very well (Conectiva Linux
8.0)!!

Netscape has a site for "Songs and Videos" where Mozilla 1.1 can reproduce with
Real Player 8 very well (Conectiva Linux 8.0)!!!

Warnerbros trailers at www.warnerbros.com don't work as well with Mozilla 1.1.
Error messages of the same type as in Radio@Netscape.
Can't say anything about Netscape 4.79 since warnerbros site doesn't allow N4.79
to get in.

Thanks,

Comment 11

15 years ago
*** Bug 194640 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
tech evang june 2003 reorg
Assignee: aruner → english-us
Component: Plugins → English US
QA Contact: mgalli → english-us
Whiteboard: [plugin]

Comment 13

15 years ago
This is bug is solved, fixed in new Mozilla issues.

Comment 14

15 years ago
Resolving as fixed due to comment 13.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 15

14 years ago
*** Bug 213686 has been marked as a duplicate of this bug. ***
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.