Mail app crashes just reading message list because of specific email

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
blocker
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Michael Baffoni, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6+) Gecko/20011124

Just opening a folder (IMAP, over SSL) with this message in it causes the 3-pane
folder view (and the others I would suppose - not tested) to crash.  This occurs
in both classic and modern themes.  Deleting inbox.msf (or any other folder for
that matter) does not help - it downloads the headers then crashes - I can move
the message out of the folder and it will download the headers and I can read
messages, but as soon as I move the message back into the folder, it crashes.

I CAN read this message in Netscape Communicator 4.79, and Netscape 6.2.  It
crashed in the build above and a build from a couple of days ago.  I've got
several crash data (figuring out which message caused this):  TB38460251H,
TB38460247E, TB38459494G, TB38458896Y, TB38458844Y, TB38458437G, TB38457844Z,
TB38457187K, TB38456897Y, TB38456770X, TB38446618G, TB38411959E, TB38411955Y,
TB38411744W.  I'll attach the email source.
(Reporter)

Comment 1

17 years ago
Created attachment 59077 [details]
Source of email that crashes mail client

This crashes during the getting of the IMAP headers, but I can open the email
without problem when I save the source to email.eml, and then drag to an open
browser (of course that doesn't display everything like the mail client ...).
(Reporter)

Comment 2

17 years ago
I verified that this doesn't crash on an 11/20 build, but does with
11/24-today's build, and I got the same crash on a second windows 2000 computer
that accessed the same IMAP folders (but not over SSL).  If it matters, the IMAP
server is a Netscape MS4.15p6 running on Windows NT4.0, sp6.
(Reporter)

Comment 3

17 years ago
Looks like this has been fixed in the 2001112703 build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
verified, per reporter's comments.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.