Intermittent test_bug937006.html | application crashed [@ js::gc::AutoStopVerifyingBarriers::~AutoStopVerifyingBarriers()]

RESOLVED FIXED in Firefox 37

Status

()

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: cbook, Assigned: sfink)

Tracking

({assertion, crash, intermittent-failure})

Trunk
mozilla38
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox36 unaffected, firefox37 fixed, firefox38 fixed, firefox-esr31 unaffected, b2g-v2.2 fixed, b2g-master fixed)

Details

()

Attachments

(2 attachments, 2 obsolete attachments)

Reporter

Description

5 years ago
Ubuntu VM 12.04 mozilla-central debug test mochitest-2

https://treeherder.mozilla.org/logviewer.html#?job_id=840870&repo=mozilla-central

06:17:46 INFO - Assertion failure: gc->stats.currentPhase() == gcstats::PHASE_NONE, at /builds/slave/m-cen-lx-d-0000000000000000000/build/src/js/src/gc/GCInternals.h:128 

06:18:01 WARNING - PROCESS-CRASH | dom/indexedDB/test/test_bug937006.html | application crashed [@ js::gc::AutoStopVerifyingBarriers::~AutoStopVerifyingBarriers()]
06:18:01 INFO - Crash dump filename: /tmp/tmpzBtxCN.mozrunner/minidumps/6da4d1dc-76ad-0750-53de1a33-13d3c15a.dmp
06:18:01 INFO - Operating system: Linux
06:18:01 INFO - 0.0.0 Linux 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686
06:18:01 INFO - CPU: x86
06:18:01 INFO - GenuineIntel family 6 model 44 stepping 2
06:18:01 INFO - 1 CPU
06:18:01 INFO - Crash reason: SIGSEGV
06:18:01 INFO - Crash address: 0x0
06:18:01 INFO - Thread 0 (crashed)
06:18:01 INFO - 0 libxul.so!js::gc::AutoStopVerifyingBarriers::~AutoStopVerifyingBarriers() [GCInternals.h:d4337ad821a0 : 128 + 0x18]
06:18:01 INFO - eip = 0xb4891a58 esp = 0xbfba7260 ebp = 0xbfba7288 ebx = 0xb6e6381c
06:18:01 INFO - esi = 0xbfba74b8 edi = 0x0000002d eax = 0x00000000 ecx = 0xb76348ac
06:18:01 INFO - edx = 0x00000000 efl = 0x00210282
06:18:01 INFO - Found by: given as instruction pointer in context
06:18:01 INFO - 1 libxul.so!js::Nursery::collect(JSRuntime*, JS::gcreason::Reason, js::Vector<js::types::TypeObject*, 0u, js::SystemAllocPolicy>*) [Nursery.cpp:d4337ad821a0 : 914 + 0x1b]
06:18:01 INFO - eip = 0xb4896347 esp = 0xbfba7290 ebp = 0xbfba75c8 ebx = 0xb6e6381c
06:18:01 INFO - esi = 0xad8da1e8 edi = 0xad8da000
06:18:01 INFO - Found by: call frame info
06:18:01 INFO - 2 libxul.so!js::gc::GCRuntime::minorGCImpl(JS::gcreason::Reason, js::Vector<js::types::TypeObject*, 0u, js::SystemAllocPolicy>*) [jsgc.cpp:d4337ad821a0 : 6495 + 0x1e]
06:18:01 INFO - eip = 0xb4b0bebc esp = 0xbfba75d0 ebp = 0xbfba7628 ebx = 0xb6e6381c
06:18:01 INFO - esi = 0xad8da1bc edi = 0xbfba75fc
06:18:01 INFO - Found by: call frame info
06:18:01 INFO - 3 libxul.so!js::IterateGrayObjects(JS::Zone*, void (*)(void*, JS::GCCellPtr), void*) [GCRuntime.h:d4337ad821a0 : 325 + 0x4]
06:18:01 INFO - eip = 0xb4874d75 esp = 0xbfba7630 ebp = 0xbfba76c8 ebx = 0xb6e6381c
06:18:01 INFO - esi = 0xad8e047c edi = 0xad8da1bc
06:18:01 INFO - Found by: call frame info
06:18:01 INFO - 4 libxul.so!mozilla::CycleCollectedJSRuntime::TraverseZone(JS::Zone*, nsCycleCollectionTraversalCallback&) [CycleCollectedJSRuntime.cpp:d4337ad821a0 : 702 + 0x12]
06:18:01 INFO - eip = 0xb26bc70c esp = 0xbfba76d0 ebp = 0xbfba7728 ebx = 0xb6e6381c
06:18:01 INFO - esi = 0x633b40a0 edi = 0xbfba76f0
06:18:01 INFO - Found by: call frame info
06:18:01 INFO - 5 libxul.so!mozilla::JSZoneParticipant::Traverse(void*, nsCycleCollectionTraversalCallback&) [CycleCollectedJSRuntime.cpp:d4337ad821a0 : 368 + 0xa]
06:18:01 INFO - eip = 0xb26bc76a esp = 0xbfba7730 ebp = 0xbfba7748 ebx = 0xb6e6381c
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Component: JavaScript Engine → JavaScript: GC
Flags: needinfo?(sphink)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 9

5 years ago
Looks like the assert was just too strict. With the included tests, I was able to easily reproduce.

I really should split off the test stuff into a shell gc object or something. js.cpp is crazy big.
Attachment #8546860 - Flags: review?(terrence)
Assignee

Updated

5 years ago
Assignee: nobody → sphink
Status: NEW → ASSIGNED
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment on attachment 8546860 [details] [diff] [review]
Fix assertion in AutoStopVerifyingBarriers and add tests

Review of attachment 8546860 [details] [diff] [review]:
-----------------------------------------------------------------

Neat!
Attachment #8546860 - Flags: review?(terrence) → review+
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Reporter

Comment 27

5 years ago
https://hg.mozilla.org/mozilla-central/rev/4f64a711181d
https://hg.mozilla.org/mozilla-central/rev/33394bd63ec0
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Duplicate of this bug: 1117548
I can haz Aurora/Beta noms? :)
Assignee

Comment 30

5 years ago
Hopefully this will upload the right patch. Using bzexport without mq.
Assignee

Comment 31

5 years ago
I hope this isn't spamming the bug.
Assignee

Comment 32

5 years ago
Please ignore the bug spam. I am a bad person.
Assignee

Updated

5 years ago
Attachment #8549270 - Attachment is obsolete: true
Assignee

Updated

5 years ago
Attachment #8549279 - Attachment is obsolete: true
Flags: needinfo?(sphink)
Assignee

Comment 33

5 years ago
Comment on attachment 8549258 [details] [diff] [review]
Patch for uplift: Fix assertion in AutoStopVerifyingBarriers and add tests,

Approval Request Comment
[Feature/regressing bug #]: bug 1104162 which was a fix for bug 1068123
[User impact if declined]: none
[Describe test coverage new/current, TBPL]: on inbound. Looks like it has stopped the flow of intermittents.
[Risks and why]: Main risk is that because it adds a test, the test could fail on old branches. But we could just remove it then. :-) But the actual change is just an assertion loosening, so this has no effect on opt builds and can only result in fewer asserts in debug builds. 
[String/UUID change made/needed]: none
Attachment #8549258 - Attachment description: Fix assertion in AutoStopVerifyingBarriers and add tests, → Patch for uplift: Fix assertion in AutoStopVerifyingBarriers and add tests,
Attachment #8549258 - Flags: approval-mozilla-beta?
Attachment #8549258 - Flags: approval-mozilla-aurora?
Attachment #8549258 - Flags: approval-mozilla-beta?
Attachment #8549258 - Flags: approval-mozilla-beta+
Attachment #8549258 - Flags: approval-mozilla-aurora?
Attachment #8549258 - Flags: approval-mozilla-aurora+
Assignee

Comment 36

5 years ago
Turns out that the triggering patch never landed on beta.
Attachment #8549258 - Flags: approval-mozilla-beta+

Updated

4 years ago
Blocks: 1182647
You need to log in before you can comment on or make changes to this bug.