Investigate test_persona_standard_sign_in intermittent failure

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: RobertC, Assigned: Martijn Wargers (zombie))

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [from automation])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/87/HTML_Report/

test_persona_standard_sign_in is failing intermittently on Jenkins with the following error:

Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/marionette_test.py", line 268, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/tests/functional/persona/test_persona_app.py", line 38, in test_persona_standard_sign_in
persona.login(self.user.email, self.user.password)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/apps/persona/app.py", line 30, in login
self.type_email(email)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/apps/persona/app.py", line 60, in type_email
self.keyboard.dismiss()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/apps/keyboard/app.py", line 352, in dismiss
%(input_window.is_displayed(), input_window.get_attribute('class')))
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 29.5 seconds with message: Keyboard was not dismissed. Debug is_displayed(): False, class: inputWindow top-most.

The issue is not reproduced manually.
With automation I got a reproduction rate of 2 out of 10 on my local device.

From the screenshot it looks like the keyboard fails to close after typing the email.

Build info flame v2.2 319MB Full-Flash:
Device firmware (base) 	L1TC10011880
Device firmware (date) 	05 Jan 2015 01:34:36
Device firmware (incremental) 	eng.cltbld.20150105.043425
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	02 Jan 2015 16:08:34
Gaia revision 	c2bf20d23851
Gecko build 	20150105010205
Gecko revision 	636498d041b5
Gecko version 	37.0a1
(Reporter)

Updated

3 years ago
QA Whiteboard: [fxosqa-auto-backlog+]
(Assignee)

Updated

3 years ago
Assignee: nobody → martijn.martijn
QA Whiteboard: [fxosqa-auto-backlog+] → [fxosqa-auto-backlog+][fxosqa-auto-s8]
(Assignee)

Updated

3 years ago
QA Whiteboard: [fxosqa-auto-backlog+][fxosqa-auto-s8] → [fxosqa-auto-backlog+]
(Assignee)

Updated

3 years ago
QA Whiteboard: [fxosqa-auto-backlog+] → [fxosqa-auto-s8]
Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg/marionette/marionette_test.py", line 283, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/tests/functional/persona/test_persona_app.py", line 38, in test_persona_standard_sign_in
persona.login(self.user.email, self.user.password)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/apps/persona/app.py", line 35, in login
self.type_email(email)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/apps/persona/app.py", line 65, in type_email
self.keyboard.dismiss()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/apps/keyboard/app.py", line 345, in dismiss
%(input_window.is_displayed(), input_window.get_attribute('class')))
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg/marionette/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 28.5 seconds with message: Keyboard was not dismissed. Debug is_displayed(): True, class: inputWindow top-most active.


This has reproduced in today's(20150127010228) build
Keywords: intermittent-failure
Summary: [v2.2] Investigate test_persona_standard_sign_in intermittent failure → Investigate test_persona_standard_sign_in intermittent failure
Whiteboard: [from automation]
(Assignee)

Comment 2

3 years ago
I could fix this intermittent failure by using self.keyboard.send(value) in persona app.py, but then you get slow typing again.
I think this could also be fixed by switching context to the keyboard first in the keyboard dismiss() function.
Created attachment 8561776 [details] [review]
[PullReq] mwargers:persona to mozilla-b2g:master
(Assignee)

Comment 4

3 years ago
Comment on attachment 8561776 [details] [review]
[PullReq] mwargers:persona to mozilla-b2g:master

This passes 11 times on my device (while the test would fail every time, previously) and passes on b2g desktop for me.
Attachment #8561776 - Flags: review?(jlorenzo)
Comment on attachment 8561776 [details] [review]
[PullReq] mwargers:persona to mozilla-b2g:master

Ran 31 times without any issue in the jenkins job, r+.
Attachment #8561776 - Flags: review?(jlorenzo) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.