Location bar text entered while creating a new window gets deleted

RESOLVED WORKSFORME

Status

()

defect
P3
normal
RESOLVED WORKSFORME
5 years ago
Last month

People

(Reporter: erik, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

1. Hit command-N to make a new window.
2. After the window appears but before the location bar is focused, type some text.

After a sub-second delay, part of the text you type appears in the bar: say "won" if you had typed "wonderful". Autocomplete even happens. But then, less than a second later, the text disappears, replaced with "Search or enter address". Then the remaining keystrokes you typed enter the bar one by one, leaving you with only "derful".

I would expect that, once a window appears, it is ready to receive input. At the very least, we should not show some input and later retract it.

(Nightly 2014-12-19)
Blocks: 1425024
Priority: -- → P3
Whiteboard: [DUPEME]

Is this still happening in Nightly? I tried a few times but couldn't reproduce, likely thanks to the many perf improvements we had in the past years.

Flags: needinfo?(erik)

On my 2017 MBP, I can't repro it.

But on my 2012, something new happens:

  1. Be in a window with the location bar focused.
  2. Hit command-N.
  3. Before the new window appears, start typing "abcde".
  4. "ab" appears in the old window.
  5. The new window appears.
  6. "cde" appears in the new window.

It's a definite improvement, probably not ideal from a workflow standpoint, but I'm okay closing this. I don't think we have this particular race anymore. And you have to be pretty fast, even on the 2012.

Flags: needinfo?(erik)

ok thanks. it's possible that opening a new window became slower, or mostly that it became more async, so the events are still handled by the current one...

Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.