localtags file is growing to epic proportions

RESOLVED DUPLICATE of bug 1115188

Status

Developer Services
Mercurial: firefoxtree
RESOLVED DUPLICATE of bug 1115188
3 years ago
2 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
I have a local server that is pulling from the four main channels every minute into four separate clones. Apparently with every pull the .hg/localtags file gets the latest fxhead appended to it rather than updated so they are now up to around 20000 lines. All of them giving a changeset for the same tag, many of them exact duplicates.

Also somehow one of the clones has ended up with a line in localtags that looks like this: "@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@" and so every invocation of hg now says "localtags, line 10594: cannot parse entry"

Comment 1

3 years ago
The "@@@@@" line is an interesting bug. That's separate from the issue that the file gets too big.

The reason why the file grows indefinitely is a Mercurial implementation detail that I don't feel like explaining right now. Suffice to say, if you are pulling every minute, you are going to have a bad time until Mercurial 3.3 is released and firefoxtree is ported to its APIs.

In the mean time, unless you are running some esoteric extension that is also writing to the .hg/localtags file, it is safe to delete the .hg/localtags file any time: firefoxtree will recreate it with appropriate content on next pull. You may want to delete it before your automated pulls.

Comment 2

2 years ago
Being fixed in the series posted to bug 1115188.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1115188
You need to log in before you can comment on or make changes to this bug.