:hover breaks P:first-letter

RESOLVED DUPLICATE of bug 23604

Status

()

RESOLVED DUPLICATE of bug 23604
17 years ago
17 years ago

People

(Reporter: mozilla, Assigned: dbaron)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6+)
Gecko/20011123
BuildID:    2001112303

When :hover is defined for a link, and a link begins at the start of a paragraph
that defines a different style for :first-letter, when you hover over the link,
the :first-letter style is clobbered.

Reproducible: Always
Steps to Reproduce:
1.Load http://www.morons.org/articles/6/952
2.Hover over the "According to the Sun News" link


Actual Results:  The enlarged "A" in "According to the Sun News" changes to the
font size of the rest of the paragraph.

Expected Results:  No change to the :first-letter of the paragraph when hovering
over the link.

Looks like this was broken at least back to 0.9.5.
Style system.  Seeing this on Linux as well.
Assignee: attinasi → dbaron
Status: UNCONFIRMED → NEW
Component: Layout → Style System
Ever confirmed: true
OS: Windows NT → All
QA Contact: petersen → ian
Hardware: PC → All

*** This bug has been marked as a duplicate of 23604 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.