debugger statement in the eval'ed scripts does not work on page reload

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
2 months ago

People

(Reporter: yury, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Posted file debug.html
STR:
1. Open Firefox (new process and new profile) and its devtools on Debugger tab;
2. Open the attached debug.html
3. Wait when script breaks
4. Hit Cmd+R to reload page multiple times

Notice that debugger does not break anymore and more than one "debug.html > eval" appeared in the list of the scripts.
Version: 33 Branch → Trunk
Noticed error message in the console:

Handler function DebuggerProgressListener.prototype.onStateChange threw an exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIRequest.suspend]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/webbrowser.js :: TabActor.prototype._willNavigate :: line 1430"  data: no]
Stack: TabActor.prototype._willNavigate@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/webbrowser.js:1430:6
DebuggerProgressListener.prototype.onStateChange<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/webbrowser.js:2139:6
makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:83:13
TabActor.prototype.onReload/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/webbrowser.js:1151:0
makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:83:13
EventLoop.prototype.enter@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/script.js:363:4
ThreadActor.prototype._pushThreadPause@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/script.js:572:4
ThreadActor.prototype._pauseAndRespond@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/script.js:771:6
ThreadActor.prototype.onDebuggerStatement@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/script.js:1898:8
anonymous/<@https://bug1117940.bugzilla.mozilla.org/attachment.cgi?id=8544155 line 8 > Function:1:0
@https://bug1117940.bugzilla.mozilla.org/attachment.cgi?id=8544155:9:4
Line: 1430, column: 0
behavior in e10s is as defined above. With non-e10s I see only two "> eval" script, that look the same. Which one will allow set breakpoints?
I can't reproduce this, and I don't really know how to parse XPCOM errors (isn't that from XPCOM? certainly from the platform component layer).

(In reply to Yury Delendik (:yury) from comment #2)
> behavior in e10s is as defined above. With non-e10s I see only two "> eval"
> script, that look the same. Which one will allow set breakpoints?

I also don't see his, I see the original HTML file and the eval script: http://jlongster.com/s/function-eval.png

Any particular build settings or context I should try?
Attachment #8548464 - Attachment description: Screencast to reproduce the bug (part 2, non-e10s) → Screencast to reproduce the bug (part 2, e10s)
Summary: debugger statement in the eval'ed scripts does not work on page load → debugger statement in the eval'ed scripts does not work on page reload
Product: Firefox → DevTools

Yury, does this still happen for you?

this works for me now

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.