Setup and deliver OOPP plugin streams asynchronously

RESOLVED DUPLICATE of bug 998863

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 998863
3 years ago
3 years ago

People

(Reporter: Benjamin Smedberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Currently OOPP plugin streams are set up synchronously (the NPP_NewStream call) and then delivered asynchronously. The NPP_NewStream call is a major source of browser jank; currently it's synchronous because we need to know whether the plugin wants the stream as a file or just as data, but that's something plugin-container could deal with all itself.

I think we should try to make this all async and see what happens.
It's already done as part of async plugin init.

Profiles were showing that async NPP_New wasn't enough; once we finished initializing we'd hit a wall of jank due to a bunch of NPP_NewStream calls that were queued up.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 998863
You need to log in before you can comment on or make changes to this bug.