[W] MLK: Memory leak of 1080 bytes from 30 blocks allocated in JS_malloc

VERIFIED INVALID

Status

()

Core
JavaScript Engine
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Navin Gupta, Assigned: Kenton Hanson (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Running mail with one pop acct. reading some messages, sorting and exiting.

    Distribution of leaked blocks
    Allocation location
        malloc         [dbgheap.c:129]
        JS_malloc      [jsapi.c:1411]
        js_NewScopeProperty [jsscope.c:521]
        js_DefineProperty [jsobj.c:1989]
        js_DefineFunction [jsfun.c:1971]
        JS_DefineFunction [jsapi.c:2813]
        JS_DefineFunctions [jsapi.c:2795]
        JS_InitClass   [jsapi.c:1849]
        js_InitObjectClass [jsobj.c:1528]
        InitFunctionAndObjectClasses [jsapi.c:1068]

Comment 1

17 years ago
*** Bug 111802 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
From the duplicate bug 111802:
Same steps as above:

        Distribution of leaked blocks
        Allocation location
            malloc         [dbgheap.c:129]
            JS_malloc      [jsapi.c:1411]
            js_NewScript   [jsscript.c:748]
            js_NewScriptFromParams [jsscript.c:767]
            js_NewScriptFromCG [jsscript.c:804]
            js_EmitFunctionBody [jsemit.c:1732]
            js_EmitTree    [jsemit.c:1810]
            Statements     [jsparse.c:927]
            js_CompileTokenStream [jsparse.c:392]
            CompileTokenStream [jsapi.c:2831]

Comment 3

17 years ago
cc'ing Brendan to ask if this is worth pursuing further. Compare
bug 111779, bug 111780 against XPConnect, which jband closed as follows:

------- Additional Comment #1 From John Bandhauer 2001-11-24 22:54 -------
We decided in bug 99145 that these leaf leaks are not worth chasing.
*** This bug has been marked as a duplicate of 99145 *** 
Assignee: rogerl → khanson
Yup, this bug is invalid.  Use the memory tools documented at
http://lxr.mozilla.org/mozilla/source/xpcom/doc/MemoryTools.html to find the
leak roots.  Do not report bugs on the leaf and non-root leaks, they're useless.
 The leak root here is very likely to be an XPCOM object somewhere that holds
(via a cycle, perhaps) the global object.

/be
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
Thank you - marking Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.