Request to add Igbo, Yoruba, Hausa and Burmese locales on gaia-l10n builds (multiple branches)

RESOLVED DUPLICATE of bug 1122328

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 1122328
3 years ago
3 years ago

People

(Reporter: delphine, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 obsolete attachments)

Repos have been set up in Bug 1113426. We can now go ahead and get these locales up on builds.
Repos will be empty at first - please wait until they are not empty anymore before merging
Created attachment 8544301 [details] [review]
Patch for gaia master, all locales
Attachment #8544301 - Flags: review?(stas)
Summary: Request to add gaia-l10n builds for Igbo, Yoruba, Hausa and Burmese locales → Request to add Igbo, Yoruba, Hausa and Burmese locales on gaia-l10n builds (multiple branches)
Created attachment 8544303 [details] [review]
Patch for gaia 2.1, all locales
Attachment #8544303 - Flags: review?(stas)
Created attachment 8544304 [details] [review]
Patch for 2.0, all locales
Attachment #8544304 - Flags: review?(stas)
Hey Theo! Mind adding a Readme to the empty repos, for these locales and on all those branches please?
I believe "my" locale has content already on master, but that's the only case. Thanks :)
Flags: needinfo?(theo.chevalier11)
Sure thing, will do tonight after my exams.

Looks like "my" has content on 2.1 and 2.0 as well, so I'll just initiate ig, yo, ha.
Pushed dummy readme file to all repos, safe to merge now :)

https://hg.mozilla.org/releases/gaia-l10n/v2_0/yo/rev/57d2594fc970
https://hg.mozilla.org/releases/gaia-l10n/v2_1/yo/rev/57d2594fc970
https://hg.mozilla.org/gaia-l10n/yo/rev/57d2594fc970

https://hg.mozilla.org/releases/gaia-l10n/v2_0/ha/rev/5884fdd06ef6
https://hg.mozilla.org/releases/gaia-l10n/v2_1/ha/rev/5884fdd06ef6
https://hg.mozilla.org/gaia-l10n/ha/rev/5884fdd06ef6

https://hg.mozilla.org/releases/gaia-l10n/v2_0/ig/rev/032904caaee5
https://hg.mozilla.org/releases/gaia-l10n/v2_1/ig/rev/032904caaee5
https://hg.mozilla.org/gaia-l10n/ig/rev/032904caaee5
Flags: needinfo?(theo.chevalier11)
Comment on attachment 8544301 [details] [review]
Patch for gaia master, all locales

r=me.  Please also add these locales to https://github.com/mozilla-b2g/gaia/blob/master/build/config/keyboard-layouts.json and specify English as their default keyboard for now (unless there are better choices).
Attachment #8544301 - Flags: review?(stas) → review+
Comment on attachment 8544303 [details] [review]
Patch for gaia 2.1, all locales

r=me + the same comment about keyboard-layouts.json as above.
Attachment #8544303 - Flags: review?(stas) → review+
Comment on attachment 8544304 [details] [review]
Patch for 2.0, all locales

r=me + the same comment about keyboard-layouts.json as above.
Attachment #8544304 - Flags: review?(stas) → review+
Duplicate of this bug: 1111509

Updated

3 years ago
Keywords: checkin-needed
Removing checkin-needed, because we still need to handle keyboards (please see thread on l10n-drivers ML)
Keywords: checkin-needed

Comment 12

3 years ago
My bad! Thanks for catching that.
Let's use bug 1122328 instead of this one and land everything (other requested locales + keyboards) there for the sake of simplicity.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1122328
Attachment #8544301 - Attachment is obsolete: true
Attachment #8544303 - Attachment is obsolete: true
Attachment #8544304 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.