Can't enter 0.1MB as value for data usage limit in the cost control app

VERIFIED FIXED in 2.2 S4 (23jan)

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: martijn.martijn, Assigned: mai)

Tracking

({regression})

unspecified
2.2 S4 (23jan)
x86
Mac OS X
regression

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
This is reproducable with:
Gaia-Rev        698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/13fe5ad0364d
Build-ID        20150102010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880

I think this used to work with a build from a week ago or so.

Steps to reproduce:
- Start up Usage app
- Tap on the Settings icon
- Tap on select just under "When use is above" -> Data usage limit dialog opens
- Try to enter "0.1" as value in the input at the bottom

Expected result:
- 0.1 is entered as value

Actual result:
- 0.1 is not accepted as value

This prevents bug 1115180 to be re-enabled.
(Reporter)

Updated

4 years ago
Summary: Can't enter → Can't enter 0.1MB as value for data usage limit in the cost control app
Marina, Vivien, can you please take a look over this issue? 
We cannont re-enable a smoketest because of this.
Thanks!
Flags: needinfo?(marina.rodrigueziglesias)
Flags: needinfo?(21)
(Assignee)

Updated

4 years ago
Assignee: nobody → marina.rodrigueziglesias
Flags: needinfo?(marina.rodrigueziglesias)
(Assignee)

Comment 2

4 years ago
Created attachment 8548692 [details] [review]
patch v1.0

Hi Salva, 
would you mind reviewing the patch?
Regards
Flags: needinfo?(21)
Attachment #8548692 - Flags: review?(salva)
Comment on attachment 8548692 [details] [review]
patch v1.0

Not sure. We should check with UX if unit fractions are valid values. Delaying review until feedback from UX is provided.

Juwei, could you please tell us if 0.1M or 0.1G are valid values for data alerts?
Flags: needinfo?(jhuang)
Attachment #8548692 - Flags: review?(salva)
Hi,
0.1 makes sense to me.
Thanks.
Flags: needinfo?(jhuang)
Comment on attachment 8548692 [details] [review]
patch v1.0

Marina, address the comments on GitHub and ask for my review again.

Thank you!
(Assignee)

Comment 6

4 years ago
Comment on attachment 8548692 [details] [review]
patch v1.0

Updated the pr with your comments
Attachment #8548692 - Flags: review?(salva)
Comment on attachment 8548692 [details] [review]
patch v1.0

Just a little comment on GitHub.
Thank you!
Attachment #8548692 - Flags: review?(salva) → review+
(Assignee)

Comment 8

4 years ago
Master: ec19d7e5bf2aa35ab6628b3c2c7f96b2eae2c031
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

4 years ago
Comment on attachment 8548692 [details] [review]
patch v1.0

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1089829
[User impact] if declined: The user cannot introduce values that starts with 0. or .
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low risk
[String changes made]: No
Attachment #8548692 - Flags: approval-gaia-v2.2?(release-mgmt)
Attachment #8548692 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
I just verified and this issue is fixed in latest mozilla-central. 
I am able to insert '0.1 MB' as mobile data limit alert. 

Gaia-Rev        ebb5bd74ac660092d863c86e4ccf731b903be2e4
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/cccb55b1561d
Build-ID        20150116052200
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150116.085803
FW-Date         Fri Jan 16 08:58:13 EST 2015
Bootloader      L1TC10011880
v2.2: https://github.com/mozilla-b2g/gaia/commit/b3bc5ba88f2bef3008f975fc67e28a0d23615faf
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S4 (23jan)
Per comment 10, this bug is fixed/verified, so change status and "Tracking Flags" to "verified
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.