Closed Bug 1118155 Opened 5 years ago Closed 5 years ago

[DT][Privacy] The latitude and longitude are 0 when enable privacy control

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1093688
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: gchang, Unassigned)

References

Details

(Keywords: privacy)

Attachments

(2 files)

### Steps:
1. Go to Settings > Privacy Panel > Location Accuracy
2. Enable "Use geolocation" and "Use local adjustment" and choose "Custom Location"
3. Go to "Set custom location", check "Choose a region/city"
4. Open Geoloc app
5. Tap "Get current"

### Expected:
1. The latitude and longitude shoud have value.

### Actual:
1. All indexes including latitude and longitude are 0 in below debug log section.
2. Can't locate position in google map.

PS: If privacy control is not enabled, the latitude and longitude will have value.


### Reproduce rate
always

### Version:
Gaia-Rev        4ceeff19086b2a2955f044ad923dcfa63a293de3
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/912036eeb024
Build-ID        20150105160215
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
Blocks: Privacy
blocking-b2g: --- → 2.2?
Flags: needinfo?(jocheng)
Dear Marta,
Could you help to check this issue?
Thanks!
Flags: needinfo?(jocheng) → needinfo?(marta)
Duplicate of this bug: 1121789
blocking-b2g: 2.2? → 2.2+
In the debug scenario - do you choose any values in the drop downs?
Flags: needinfo?(marta)
In Step 3:
Go to "Set custom location", check "Choose a region/city",
I choose "America" in Region and "Los Angeles" in City.
Flags: needinfo?(marta)
This is probably combined with the bug https://bugzilla.mozilla.org/show_bug.cgi?id=1093688 so I would suggest closing it as a duplicate. Dave is working on it, but we are a bit on hold due to ideation...
Flags: needinfo?(marta)
Adding privacy keyword.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: privacy
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Status: NEW → RESOLVED
blocking-b2g: 2.2+ → ---
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1093688
No longer blocks: Privacy
See Also: → 1134707
You need to log in before you can comment on or make changes to this bug.