Closed Bug 1118163 Opened 5 years ago Closed 5 years ago

Can not open vCard in notification panel when received from PC

Categories

(Firefox OS Graveyard :: Bluetooth, defect, P2)

defect

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 verified, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.1S verified, b2g-v2.2 verified)

VERIFIED FIXED
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.0M --- verified
b2g-v2.1 --- verified
b2g-v2.1S --- verified
b2g-v2.2 --- verified

People

(Reporter: sync-1, Assigned: ben.tian)

References

Details

(Keywords: regression)

Attachments

(6 files)

Created an attachment (id=1097864)
 Pic
 
 Reporter:朱国华
 Tel:0752-2639297(61297)
 		
 
  DEFECT DESCRIPTION:
 >Can not open vCard in notification panel when received from PC  
 
  REPRODUCING PROCEDURES:
 1.Connect DUT with PC
 2.Send a vCard file from PC to DUT
 3.Wait until transmission is finished
 4.Drag down notification panel and select the vCard just received->KO
 
 >KO:It prompts "Reading from memory card" for a long time(more than 5 mins)
 
 Note:The vCard can be opened when received from another MS 
 
  EXPECTED BEHAVIOUR:
 >vCard files can be opened in notification panel when received from PC  
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Attached file LOG
Attached image Pic
Attached image Pic
after received vcard file through bluetooth from PC, it is not remove the trailing ".part" file name from mDsFile and also not rename mDsFile, so vcard file can not be open.
I'll take a look first.
Assignee: nobody → btian
Status: NEW → ASSIGNED
Component: Gaia::Bluetooth File Transfer → Bluetooth
This bug is regression of bug 1079649 and happens on Flame m-c, 2.1, and 2.0 as well.
Keywords: regression
Summary: [FFOS2.0][Woodduck][BT]Can not open vCard in notification panel when received from PC → Can not open vCard in notification panel when received from PC
blocking-b2g: --- → 2.0M?
The cause is that gecko bluetooth doesn't remove trailing ".part" from received file name while receiving small-size file (within 1 packet).

Changes of attached patch
- handle small-size file case.
- refactor to reuse file related functions:
  * integrate |DeleteDummyFile| and |NotifyAboutFileChange| functions into |RecoverFileName|, and rename it to |RestoreReceivedFile|.
  * remove |DeleteDummyFile| function.
Attachment #8545069 - Flags: review?(shuang)
Comment on attachment 8545069 [details] [diff] [review]
Patch 1 (v1): Restore received file for small size (1-packet) file

Review of attachment 8545069 [details] [diff] [review]:
-----------------------------------------------------------------

It looks like to me.

::: dom/bluetooth/bluedroid/BluetoothOppManager.cpp
@@ +584,3 @@
>  
> +  // Notify about change of received file
> +  NotifyAboutFileChange();

Is it more clear to keep NotifyAboutFilechange outside RestoreNotifyReceivedFile?
Attachment #8545069 - Flags: review?(shuang) → review+
blocking-b2g: 2.0M? → 2.0M+
https://hg.mozilla.org/mozilla-central/rev/ccd36ead0046
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8545069 [details] [diff] [review]
Patch 1 (v1): Restore received file for small size (1-packet) file

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  1079649
User impact if declined: 
  Fail to receive small size files (e.g., vCard and small size pictures) via bluetooth.
Testing completed: 
  - Verified on m-c and 2.0m branches.
  - try server: https://treeherder.mozilla.org/#/jobs?repo=try&revision=76a2651074b8
Risk to taking this patch (and alternatives if risky): 
  None
String or UUID changes made by this patch:
  None
Attachment #8545069 - Flags: approval-mozilla-b2g34?
Attachment #8545069 - Flags: approval-mozilla-b2g32?
Requesting QA verification on a 2.2 build, before uplifting this. Mike, looks like you helped verify 1079649 so NI you here to help with verification. Thanks!
Flags: needinfo?(mlien)
verified and fixed with v2.2, tap the recieved file in notification will open vCard and import to Contacts
Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bb8d6034f5f2
Build-ID        20150111160203
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150111.192630
FW-Date         Sun Jan 11 19:26:41 EST 2015
Bootloader      L1TC00011880
Flags: needinfo?(mlien)
Attachment #8545069 - Flags: approval-mozilla-b2g34?
Attachment #8545069 - Flags: approval-mozilla-b2g34+
Attachment #8545069 - Flags: approval-mozilla-b2g32?
Attachment #8545069 - Flags: approval-mozilla-b2g32+
This bug has been successfully verified on Woodduck 2.0 and Flame v2.0&2.1&2.2.
See attachment: verified.mp4
Reproduce rate: 0/5

STR:
1.Paired DUT with PC.
2.Send a vCard file from PC to DUT
3.Wait until transmission is finished
4.Drag down notification panel and select the vCard just received.
**vCard files can be opened and imported to Contacts app.

Woodduck 2.0 build:
Gaia-Rev        ddb406ebdb34ca6717eda14297dea98f26f1f412
Gecko-Rev       20943fe7b54c63a375952fbd8dd396a22ee893e7
Build-ID        20150114050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1421183152
FW-Date         Wed Jan 14 05:06:17 CST 2015

Flame 2.0 build:
Gaia-Rev        31d6c9422cd0a8213df9f96019c9ab7168ec3ab3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f2b6017e84eb
Build-ID        20150113160201
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150113.192825
FW-Date         Tue Jan 13 19:28:37 EST 2015
Bootloader      L1TC000118D0

Flame 2.1 build:
Gaia-Rev        6957ac8a322234ec99c8abb7cc18dc6a2e0176db
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6600eba54256
Build-ID        20150113161204
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150113.192836
FW-Date         Tue Jan 13 19:28:47 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150113162504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150113.194114
FW-Date         Tue Jan 13 19:41:25 EST 2015
Bootloader      L1TC000118D0
please close it, thanks.
Hi Reporter,

    Could you please tell me what is your device storage when you found this bug on 2.1S ?  512M or 256M?

Thank you very much.
Flags: needinfo?(sync-1)
from application storage show is only 81.9M.
(In reply to sync-1 from comment #23)
> from application storage show is only 81.9M.

Sorry, I meant the v2.1S phone memory, not storage, you can get the "MemTotal" using below command: " adb shell cat /proc/meminfo ", thank you very much.
MemTotal:         214748 kB
(In reply to sync-1 from comment #25)
> MemTotal:         214748 kB

Thanks!


This bug has been successfully verified on latest v2.1S.
See attachment: verified_v2.1S.mp4
Reproduce rate: 0/5

2.1S (256m):
Build ID               20150208161201
Gaia Revision          bca70e96979fbd714012dc442a92b9fa156f63f7
Gaia Date              2015-02-03 00:37:47
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/afac5ac46ff6
Gecko Version          34.0
Device 
Name            scx15_sp7715ga
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.194618
Firmware Date          Sun Feb  8 19:46:30 EST 2015
Flags: needinfo?(sync-1)
You need to log in before you can comment on or make changes to this bug.