If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

find dialog not disabled when it should be

VERIFIED DUPLICATE of bug 37158

Status

SeaMonkey
MailNews: Message Display
--
trivial
VERIFIED DUPLICATE of bug 37158
16 years ago
13 years ago

People

(Reporter: Emanuel Gull, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6) Gecko/20011120
BuildID:    200112009

Under certain circumstances the find dialog is not disabled when it should be.
I'm using an imap mail account with multiple folders on the server. Try my steps
to reproduce it.

Reproducible: Always
Steps to Reproduce:
1. Open mail, log on to imap server, and press control-f. There is no mail
displayed, so the find dialog doesn't show up, everything correct.
2.Choose another imap folder - like sent, drafts, or one of your private folders.
3.After the headers have loaded, do NOT click on any message, but click
control-f. There is still no message displayed in the message window, but there
is a find dialog showing up.

I think that the find dialog and the find again button should be grayed when
there is no message...

Actual Results:  I got a find dialog, but no message it was searching. No
crashes or so, fortunately

Expected Results:  Grayed find dialog if there's no message to display

It's not an important bug at all. Please don't waste your time on fixing it if
you don't think you have to.

Comment 1

16 years ago
Is this an IMAP only problem, or does it also apply to POP3? If it's IMAP only, why?
(Reporter)

Comment 2

16 years ago
I added a pop mail account to test that. It seems that with POP the find dialog
is implemented correctly. So it's only an IMAP problem... It also seems that the
menu entry for the find dialog 'is' grayed, but the control-f works with imap.
After pressing control f and closing the find dialog, the menu entry is no
longer grayed.

Why? I don't know where I can get the source code from, but if you tell me I can
have a look at it.

Updated

16 years ago
QA Contact: esther → laurel

Comment 3

16 years ago
dup of bug 37158?
(Reporter)

Comment 4

16 years ago
I filed the bug last November.. quite some time has passed since then, and it
seems that the bug was fixed. At least I can't reproduce it anymore with Windows
RC3.

I suggest that we choose resolved-worksforme. OK?

PS: It really seems to be a duplicate of 37158... so maybe someone should ask
them if they still have a way to reproduce their problem.

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 37158 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.