Closed Bug 1118239 Opened 5 years ago Closed 5 years ago

Email address selected is different with autocomplete and enter than mouse selection in thunderbird 31.3.0 (address book problem ?)

Categories

(Thunderbird :: Address Book, defect)

31 Branch
x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1107844

People

(Reporter: eric.thivant, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

With the new version of thunderbird 31.3.0, press Cmd+N to open a new browser window, then click to TO: or CC: then write the beginning of a letter, and select a name in the list of your bookmark. But please choose another email in the list (second or third email for example)with your mouse or with the arrows keys on the keyboard. normally it's a autocomplete field and then the new email address choosen should appear on the field "TO:". then leave the cursor on this field and then click to Entr.  


Actual results:

Instead of showing my selected email address from the list of my address book in the TO: field, it shows the first email adress of the list (the first entry of the list in my address book). It's the same problem for the BCC or CC: field


Expected results:

The selected email from the list of my address book should appear... if you click on the <space> bar + Enter, then the right email stays on the field TO: or CC: or BCC:
do you think the Bug 434504 - ontextentered function called whenever enter is pressed in autocomplete textbox can be helpful for explaining the problem?
https://bugzilla.mozilla.org/show_bug.cgi?id=434504
Summary: Email address selected is different with autocomplete and enter than juste using the mouse in thunderbird 31.3.0 (address book problem ?) → Email address selected is different with autocomplete and enter than mouse selection in thunderbird 31.3.0 (address book problem ?)
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1107844
You need to log in before you can comment on or make changes to this bug.