Intermittent test_dataChannel_basicAudioVideoCombined.html ,test_dataChannel_basicAudioVideoNoBundle.html,test_dataChannel_basicVideo.html | Failed to properly close data channels

RESOLVED FIXED in Firefox 37

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: RyanVM, Assigned: mt)

Tracking

({intermittent-failure})

Trunk
mozilla38
ARM
Android
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox36 unaffected, firefox37 fixed, firefox38 fixed, firefox-esr31 unaffected)

Details

(Reporter)

Description

4 years ago
20:18:32 INFO - 1519 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannelWrapper (pcLocal_channel_2) is in state: 'open'
20:18:32 INFO - 1520 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannelWrapper (pcRemote_channel_2) is in state: 'open'
20:18:32 INFO - 1521 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannelWrapper (pcRemote_channel_2) is of binary type 'blob'
20:18:32 INFO - 1522 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannelWrapper (pcRemote_channel_2) is in state: 'open'
20:18:32 INFO - 1523 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannelWrapper (pcLocal_channel_2) id is:5
20:18:32 INFO - 1524 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannelWrapper (pcLocal_channel_2) protocol is:foo/bar
20:18:32 INFO - 1525 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannelWrapper (pcLocal_channel_2) reliable is:false
20:18:32 INFO - 1526 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannelWrapper (pcRemote_channel_2) id is:5
20:18:32 INFO - 1527 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannelWrapper (pcRemote_channel_2) protocol is:foo/bar
20:18:32 INFO - 1528 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannelWrapper (pcRemote_channel_2) reliable is:false
20:18:32 INFO - 1529 INFO Run step: SEND_MESSAGE_THROUGH_LAST_OPENED_CHANNEL2
20:18:32 INFO - 1530 INFO DataChannelWrapper (pcLocal_channel_2): Sending data 'Lorem ipsum dolor sit amet'
20:18:32 INFO - 1531 INFO DataChannelWrapper (pcRemote_channel_2): 'onmessage' event fired for 'Lorem ipsum dolor sit amet'
20:18:32 INFO - 1532 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | Last channel used
20:18:32 INFO - 1533 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | Received message has the correct content.
20:18:32 INFO - 1534 INFO PeerConnectionTest.close() called
20:18:32 INFO - 1535 INFO closeDataChannels called with index: 0
20:18:32 INFO - 1536 INFO DataChannelWrapper (pcLocal_channel_0): Closing channel
20:18:32 INFO - 1537 INFO closeDataChannels called with index: 1
20:18:32 INFO - 1538 INFO DataChannelWrapper (pcLocal_channel_1): Closing channel
20:18:32 INFO - 1539 INFO closeDataChannels called with index: 2
20:18:32 INFO - 1540 INFO DataChannelWrapper (pcLocal_channel_2): Closing channel
20:18:32 INFO - 1541 INFO TEST-FAIL | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | The author of the test has indicated that flaky timeouts are expected. Reason: WebRTC inherently depends on timeouts
20:18:32 INFO - 1542 INFO DataChannelWrapper (pcRemote_channel_0): 'onclose' event fired
20:18:32 INFO - 1543 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | remoteChannel is in state 'closed'
20:18:32 INFO - 1544 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannel(s) have reached 'closed' state for data channel 0
20:18:32 INFO - 1545 INFO _closePeerConnection called with index 0
20:18:32 INFO - 1546 INFO DataChannelWrapper (pcRemote_channel_1): 'onclose' event fired
20:18:32 INFO - 1547 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | remoteChannel is in state 'closed'
20:18:32 INFO - 1548 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | DataChannel(s) have reached 'closed' state for data channel 1
20:18:32 INFO - 1549 INFO _closePeerConnection called with index 1
20:18:32 INFO - 1550 INFO DataChannelWrapper (pcRemote_channel_2): 'onclose' event fired
20:18:32 INFO - 1551 INFO TEST-PASS | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | remoteChannel is in state 'closed'
20:18:32 INFO - 1552 INFO Still waiting for DataChannel closure
20:18:32 INFO - 1553 INFO TEST-UNEXPECTED-FAIL | dom/media/tests/mochitest/test_dataChannel_basicVideo.html | Failed to properly close data channels: 2 - expected PASS
Comment hidden (Treeherder Robot)
(Reporter)

Comment 2

4 years ago
Possible fallout from bug 1112382?
Flags: needinfo?(drno)
Summary: Intermittent test_dataChannel_basicVideo.html | Failed to properly close data channels: 2 → Intermittent test_dataChannel_basicAudioVideoNoBundle.html,test_dataChannel_basicVideo.html | Failed to properly close data channels
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

4 years ago
Summary: Intermittent test_dataChannel_basicAudioVideoNoBundle.html,test_dataChannel_basicVideo.html | Failed to properly close data channels → Intermittent test_dataChannel_basicAudioVideoCombined.html ,test_dataChannel_basicAudioVideoNoBundle.html,test_dataChannel_basicVideo.html | Failed to properly close data channels
Comment hidden (Treeherder Robot)
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #2)
> Possible fallout from bug 1112382?

Bug 1112382 was intended to be a pure refactoring without any changes. But :bwc pointed out that our data channel tests had a bug since a long time.
Now the fix here http://dxr.mozilla.org/mozilla-central/source/dom/media/tests/﷒0﷓ revealed that we have bugs in our data channel implementations. I opened bug 1118398 for that, but that was under the assumption that it is only reproducible on B2G/IPC. But it seems we get it as an orange on other platforms as well. Although that might have a different reason.

I would prefer to not back out 1112382, because it just exposes the underlying problem. As I can reproduce the problem locally we could just revert line 760 if the problem shows up to often before we have found a fix for it.
Flags: needinfo?(drno)

Updated

4 years ago
Depends on: 1118398
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1118757
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1126100
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1120040
(Reporter)

Comment 56

4 years ago
Fixed by bug 1118398. We'll still need to get it uplifted.
Assignee: nobody → martin.thomson
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox36: --- → unaffected
status-firefox37: --- → affected
status-firefox38: --- → fixed
status-firefox-esr31: --- → unaffected
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

4 years ago
See Also: → bug 979627
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

4 years ago
status-firefox37: affected → fixed
You need to log in before you can comment on or make changes to this bug.