[RTL][Settings] Carats in list items are at wrong direction.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Settings
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: YeojinC, Assigned: arthurcc)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8544703 [details]
CaratsStillExisting.png

Description:
Carats in sub-menu screens(ex. Wi-Fi, SIM Manager, Call Settings, etc.) still exists. According to p.13 on Bidirectional Guidelines, carats in list items should be removed to avoid conflicting with the screen load transitions(https://mozilla.app.box.com/s/0y1amh4rwpp6brcxd1hk). 
   
Repro Steps:
1) Update a Flame device to BuildID: 20150106010234.
2) Set the device language in Arabic under Settings > Language.
3) On the main screen Settings, select any item that includes subordinate pages, such as Wi-Fi, SIM Manager, or Sound.
4) Observe the carats in list items.
  
Actual:
Carats still exist (in the same direction as the back button).
  
Expected: 
Carats are removed.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150106010234
Gaia: b77e0d56d197e0ee02d801a25c784130d888c9db
Gecko: 2a193b7f395c
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Leaving a NI on delphine to fill-in here as she has discussed this with Steph for 2.2.
Flags: needinfo?(lebedel.delphine)

Updated

3 years ago
See Also: → bug 1118893
Waiting for a confirmation in Bug 1118893 to know what decision will be taken about carats on 2.2. Keeping the ni on me for future update.
RTL triage: P2 -- will make a best effort to get this into the 2.2 release.
Priority: -- → P2
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
feature-b2g: --- → 2.2+
Assignee: nobody → arthur.chen
Status: NEW → ASSIGNED
Created attachment 8556263 [details]
link to https://github.com/mozilla-b2g/gaia/pull/27763

WIP patch in case we are going to remove the carats.
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15558/
Flags: in-moztrap+
Shine: as stated per comment 2, we are waiting for a decision in Bug 1118893 about carats visual design, to know what the expected RTL behavior for carats will be. 
As you can see in Bug 1118893, decision is leaning towards creating a new set of carats - not removing them anymore.
Once this is 100% sure, please update ALL related test cases with appropriate behavior. In the meantime, please make sure these TCs are not activated. thank you
Flags: needinfo?(yue.xia)
Hi Delphone,
Now the TCs of carats are not activated, I will keep tracking the discussion result of Bug 1118893, Once the result is 100% for sure, I will update all the TCs.
Thanks!
Flags: needinfo?(yue.xia)
Hi Arthur, I assume you're going to work on this? I noticed that decision for carats was taken for Email in Bug 1118893 (just needs final UX review but seems like that's going to happen quickly), so just wanted to give a heads up so work could get started here too and we could get consistent carats across entire UI :) 
If you're already aware, then sorry for the noise! Thanks
Flags: needinfo?(arthur.chen)
Thanks for reminding, Delphine! I'll be starting to work on this.
Flags: needinfo?(arthur.chen)
Created attachment 8559549 [details] [review]
[PullReq] crh0716:1118366 to mozilla-b2g:master
Comment on attachment 8556263 [details]
link to https://github.com/mozilla-b2g/gaia/pull/27763

EJ, the patch simply revert the direction of the carats back. There is a new design of the carats in bug 1118893 and which has not been included in gaia-icon. I'll file another bug update the icon.

Please help review the patch, thanks!
Attachment #8556263 - Flags: review?(ejchen)
Summary: [RTL][Settings] Carats in list items are not removed. → [RTL][Settings] Carats in list items are at wrong direction.
Thanks, EJ!

master: 9d40b6e7b3ff6f2cce9955493658647e96b0b039
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 15

3 years ago
    According to https://bugzilla.mozilla.org/show_bug.cgi?id=1118893 Comment 16, this issue has been verified successfully on Flame 3.0.
Reproduce rate:0/5.
Attachment:Verify_RTL_Settings.png

Flame 3.0 build:

Build ID               20150208010208
Gaia Revision          994896b89ba10cad39a87f90eeaba9ae5e17c3a6
Gaia Date              2015-02-07 19:22:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/be65d1fde126
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.050436
Firmware Date          Sun Feb  8 05:04:47 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
status-b2g-master: --- → verified

Comment 16

3 years ago
Created attachment 8561151 [details]
Verify_RTL_Settings.png
Hi Arthur. Can you ask for approval so that this also gets uplifted on 2.2 please? Thanks!
Flags: needinfo?(lebedel.delphine) → needinfo?(arthur.chen)
Comment on attachment 8556263 [details]
link to https://github.com/mozilla-b2g/gaia/pull/27763

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: The direction of the carats is incorrect.
[Testing completed]: Testing on the device.
[Risk to taking this patch] (and alternatives if risky): Low as it only changed the style.
[String changes made]: None
Flags: needinfo?(arthur.chen)
Attachment #8556263 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8556263 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/96f38ad92cb95be2b830fdddf1ed630ba937c103
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S5 (6feb)

Comment 20

3 years ago
This issue has been verified successfully on Flame 2.2.
Reproduce rate:0/5
Attachment:Verify_RTL.png

Flame 2.2 build:

Gaia-Rev        791e53728cd8018f1d7cf7efe06bbeb1179f0370
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5dec207fcbeb
Build-ID        20150212002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150212.042208
FW-Date         Thu Feb 12 04:22:18 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified

Comment 21

3 years ago
Created attachment 8563910 [details]
Verify_RTL.png
You need to log in before you can comment on or make changes to this bug.