Closed Bug 1118390 Opened 5 years ago Closed 5 years ago

Lock task manager (and browser tab view) orientation to vertical

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S5 (6feb)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: sfoster, Assigned: sfoster)

References

Details

(Whiteboard: systemsfe)

Attachments

(1 file)

For parity with 2.1 and as a stop-gap while the screenshot and task manager orientation issues are being resolved, the task manager should be locked to vertical orientation.
blocking-b2g: --- → 2.2+
Patch just calls lock/unlock orientation when showing/hiding task-manager, to ensure task-manager is always in default orientation. No luck with writing a marionette to test the expected behavior - I gather orientation support is a work-in-progress - so I've just asserted this the lock/unlock calls occur in a unit test.

This seems pretty solid from the testing I've done, nothing unexpected in the show or hide animations - excepting the known issues in bug 1100610 and bug 1107139.
Attachment #8555039 - Flags: review?(etienne)
Comment on attachment 8555039 [details] [review]
PR lock/unlock orientation in task manager

We should let the opened app |setOrientation| (and it's probably already doing it, then being overridden by the |screen.mozUnlockOrientation()| call, but I haven't checked for sure).

Ie. with browser and dialer open.
If I open the cardview from the browser then switch to the dialer. I don't want the screen orientation to be unlocked, I want the dialer to lock it to portrait.
I'm currently looking at a landscape dialer :)
Attachment #8555039 - Flags: review?(etienne) → review-
Comment on attachment 8555039 [details] [review]
PR lock/unlock orientation in task manager

Removed the unlockOrientation, this is now consistent with how we handled orientation in 1.* and before the new design landed. In the transition to 'opened' app windows will have setOrientation -> lockOrientation called via the transitionController. That is covered in the transition controller unit tests and seems to be the expectation as you indicated.
Attachment #8555039 - Flags: review- → review?(etienne)
Comment on attachment 8555039 [details] [review]
PR lock/unlock orientation in task manager

r=me with the comments addressed (one of them is optional)
Attachment #8555039 - Flags: review?(etienne) → review+
Duplicate of this bug: 1068925
Duplicate of this bug: 1103138
Duplicate of this bug: 1107332
Filed follow-up bug 1127426 for exposing defaultOrientation via Service.registerState
PR is updated with requested test change, I'll land when Gaia-Try looks good
Merged to master: https://github.com/mozilla-b2g/gaia/commit/499f79dc3ca05c7d9438473725ec3597dde7b300
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8555039 [details] [review]
PR lock/unlock orientation in task manager

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Task Manager
[User impact] if declined: Task Manager will operate in landscape, but transitions, screenshots and other details in this mode are incomplete/janky/buggy
[Testing completed]: On device, Gaia-Try
[Risk to taking this patch] (and alternatives if risky): Low risk, restores expected behavior from <= 2.1
[String changes made]: None
Attachment #8555039 - Flags: approval-gaia-v2.2?
Attachment #8555039 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Duplicate of this bug: 1103091
Blocks: 1068714
This issue is verified fixed on Flame Master and 2.2.

Result: The task manager and the browser tab view are locked to vertical mode. When the device is set in landscape mode in Browser, Gallery and Video, the task manager appears in vertical mode. Changing orientation in task manager is not allowed. 
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150319010201
Gaia: c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gecko: cf1060d8ce9f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150319002500
Gaia: 9043c11f699c15bb6072422d1dad6518d1b5ddda
Gecko: c0442d170bec
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
See Also: → 1174325
You need to log in before you can comment on or make changes to this bug.