Can not use {{num}} in rooms_list_current_conversations in loop.properties

RESOLVED FIXED in Firefox 36

Status

defect
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: unghost, Assigned: standard8)

Tracking

unspecified
mozilla38
Points:
1
Dependency tree / graph

Firefox Tracking Flags

(firefox36 fixed, firefox37 fixed, firefox38 fixed)

Details

()

Attachments

(2 attachments, 1 obsolete attachment)

Posted image Screenshot of bug
STR:
1) Download and install Russian build of Firefox 35.0 beta (which uses {{num}} in rooms_list_current_conversations, see http://hg.mozilla.org/releases/l10n/mozilla-beta/ru/file/ee50c25837e3/browser/chrome/browser/loop/loop.properties#l129 ) from https://www.mozilla.org/en-US/firefox/beta/all/
2) Click on Hello icon to open conversation.

Expected result:
Loop client windows shows: 1 активный звонок (1 Current conversation)

Actual result:
Loop client windows shows: {{num}} активный звонок ({{num}} Current conversation)
See attached screenshot.
Link to the reference string that says "you can use {{num}}"
http://hg.mozilla.org/releases/mozilla-beta/file/default/browser/locales/en-US/chrome/browser/loop/loop.properties#l307

We have at least another locale using that (gd).
Mark -- What's the best way to fix this?
Flags: needinfo?(standard8)
Yes, we use {{num}} because ONE in gd covers both 1 and 11.
Flags: needinfo?(jaws)
Jared: This fixes the issue and lets us use num as a replacable value in the string. Do you recall if there was a reason you deleted num from the arguments?
Attachment #8547770 - Flags: review?(jaws)
Assignee: nobody → standard8
backlog: --- → Fx36?
Iteration: --- → 38.1 - 26 Jan
Points: --- → 1
Flags: needinfo?(standard8)
Priority: -- → P2
Comment on attachment 8547770 [details] [diff] [review]
Cannot use {{num}} in rooms_list_current_conversations - Don't remove the num argument for plural forms, as its a valid possible value.

Review of attachment 8547770 [details] [diff] [review]:
-----------------------------------------------------------------

Ah! Good debugging. I removed it because it didn't look like it was being used outside of just determining if the plural form should be used. Obviously I was wrong. Can we include a test here to make sure people like me don't make the same mistake again in the future?
Attachment #8547770 - Flags: review?(jaws) → review+
Flags: needinfo?(jaws)
Status: NEW → ASSIGNED
Iteration: 38.1 - 26 Jan → 38.2 - 9 Feb
Attachment #8555251 - Flags: review?(jaws) → review+
https://hg.mozilla.org/integration/fx-team/rev/31f70be9d69a
Target Milestone: --- → mozilla38
https://hg.mozilla.org/mozilla-central/rev/31f70be9d69a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8555251 [details] [diff] [review]
Cannot use {{num}} in rooms_list_current_conversations - Don't remove the num argument for plural forms, as its a valid possible value.

Approval Request Comment
[Feature/regressing bug #]: Hello rooms / 1074672
[User impact if declined]: For a couple of locales, the number of conversations won't be translated and will show as "{{num}} активный звонок" - this is in the primary panel UI.
[Describe test coverage new/current, TreeHerder]: Includes a unit test, landed in m-c.
[Risks and why]: Low - simple change; includes test coverage.
[String/UUID change made/needed]: None
Attachment #8555251 - Flags: approval-mozilla-beta?
Attachment #8555251 - Flags: approval-mozilla-aurora?
Attachment #8555251 - Flags: approval-mozilla-beta?
Attachment #8555251 - Flags: approval-mozilla-beta+
Attachment #8555251 - Flags: approval-mozilla-aurora?
Attachment #8555251 - Flags: approval-mozilla-aurora+
Duplicate of this bug: 1134758
You need to log in before you can comment on or make changes to this bug.