Curated group membership visibility

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: peterbe, Assigned: williamr)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8544818 [details]
Screenshot 2015-01-06 16.07.02.png

This is best explained by looking at this group: https://mozillians.org/en-US/group/air-mozilla-contributors/ (screenshot attached of what it looks like today)

This group is a curated group. For context, these are the 9 (excluding Richard and I) amazing people who have dedicated their free time to contribute code to Air Mozilla. 

Because we (me and Richard) can't add members ourselves we sent out an email to 9 handpicked people and told them to go and join this group and we'll vouch for them there. 

However, there's pride in being a member of this group so it should be treated with respect. 

Now, another Mozillians member called "Syed Omar Faruk Towa..." (https://mozillians.org/en-US/u/soft/) has joined but he's not vouched for and I have no intention of vouching him in either. I'm sure he's a great guy who does amazing things but I don't like that it appears that he's a member of this non-mortal-amazing group of people :)

There shouldn't be 12 members. Only 11. (9 + Richard + me)

Either we need to be able to "kick users out" (might get tedious if they repeatedly and maliciously keep joining) or that we only list members who have been vouched for. 

As an "administrator" (not sure what the right lingo is) for this group I think when I view the group it should list, separately, those who have applied to join but not yet joined. But when others view the group only those who have been vouched should be listed.
I think the problem is that we only have one curator for the group.  Right now that's me.  I'm probably the one who accepted him into the group.  I just went to the group page and removed him, so there is a "remove" option. ...but I assume it's only visible to the group curator.

We should probably see if we can add a second curator, or if that's not possible, change curation from me to :peterbe.   I don't see a way to do either from the "Edit Group" page on mozillians.
(Assignee)

Comment 2

4 years ago
(In reply to Richard A Milewski[:richard] from comment #1)
> We should probably see if we can add a second curator, or if that's not
> possible, change curation from me to :peterbe.   I don't see a way to do
> either from the "Edit Group" page on mozillians.

I have changed the curator to :peterbe. Peter, you can now approve membership requests and remove members.

I'm marking this as resolved - please reopen if there is anything else you need.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Assignee: nobody → williamr
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 3

4 years ago
Thanks William but I think it still is a bug. 

1) I still only see that Richard is a curator. (I sign in as peterbe@mozilla.com)

2) It's still a problem if a mortal (not-curator) views the group and it shows people as members when they aren't.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

4 years ago
Sorry for the confusion - I mistakenly made you curator for the 'air mozilla contributors' group when I wrote comment 2.

You are now the curator of both of these groups:
https://mozillians.org/en-US/group/air-mozilla-contributors/
https://mozillians.org/en-US/group/airmozilla/

Note that the first group has membership based on request/approval, and the second group has open membership. This can be changed on the Edit Group page.

These groups look similar. Let me know if you want the groups to be merged, and if so, which group name you want to keep.
(Reporter)

Comment 5

4 years ago
It's my fault. I should have listened to Richard properly.

I thought that guy who got in appeared because he had requested to join but had yet to be vouched for. 
Turns out Richard actually, mistakenly, accepted him in independent of this vouched-for status. 

All is well with the world now and I'm now the curator of this group. Sorry for wasting your time William.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

4 years ago
No worries at all :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.