301 redirect cache should be cleared when cookies are

RESOLVED DUPLICATE of bug 1117440

Status

()

Core
Networking: Cache
RESOLVED DUPLICATE of bug 1117440
3 years ago
3 years ago

People

(Reporter: haarp, Unassigned)

Tracking

({privacy})

34 Branch
x86_64
All
privacy
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
In Firefox, the 301 redirect cache can be used as a form of cookie, which is not cleared by clearing regular cookies. One has to clear the entire cache to get rid of these redirects.

See https://rehmann.co/projects/301-Redirect-Cookie/

This has privacy implications as this method can be used by sites to store permanent information, even when the user has disabled or cleared cookies.

The 301 cache for a site should probably get cleared when the cookies are.

Updated

3 years ago
QA Whiteboard: [bugday-20140112]
Component: Untriaged → Networking: Cache
Product: Firefox → Core
See Also: → bug 696595

Updated

3 years ago
Keywords: privacy

Updated

3 years ago
QA Whiteboard: [bugday-20140112] → [bugday-20150112]
Wontfix?
(more general bug)
Component: Networking: Cache → General
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: General → Networking: Cache
Resolution: --- → DUPLICATE
Duplicate of bug: 1117440
You need to log in before you can comment on or make changes to this bug.