Intermittent browser_privacypane_1.js | application crashed [@ mozilla::layers::CompositorD3D11::HandleError(long,mozilla::layers::CompositorD3D11::Severity)] with "Assertion failure: aSeverity != DebugAssert, at gfx/layers/d3d11/CompositorD3D11.cpp:1425"

RESOLVED DUPLICATE of bug 1107718

Status

()

defect
RESOLVED DUPLICATE of bug 1107718
4 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({assertion, crash, intermittent-failure})

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Looks like bug 1089881, bug 1108862, and bug 1116812 are all possibly-related?

11:41:16 INFO - [GFX3-]: Invalid draw target type specified.
11:41:16 INFO - [GFX3-]: Invalid draw target type specified.
11:41:16 INFO - [GFX3-]: Invalid draw target type specified.
11:41:16 INFO - [GFX3-]: Invalid draw target type specified.
11:41:16 INFO - [GFX3-]: Invalid draw target type specified.
11:41:16 INFO - [GFX3-]: Invalid draw target type specified.
11:41:16 INFO - [GFX3-]: Invalid draw target type specified.
11:41:16 INFO - Assertion failure: aSeverity != DebugAssert, at c:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/src/gfx/layers/d3d11/CompositorD3D11.cpp:1425
11:41:16 INFO - #01: mozilla::layers::CompositorD3D11::VerifyBufferSize() [gfx/layers/d3d11/CompositorD3D11.cpp:1220]
11:41:16 INFO - #02: mozilla::layers::CompositorD3D11::UpdateRenderTarget() [gfx/layers/d3d11/CompositorD3D11.cpp:1230]
11:41:16 INFO - #03: mozilla::layers::CompositorD3D11::BeginFrame(nsIntRegion const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const *,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> *,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> *) [gfx/layers/d3d11/CompositorD3D11.cpp:1057]
11:41:16 INFO - #04: mozilla::layers::LayerManagerComposite::Render() [gfx/layers/composite/LayerManagerComposite.cpp:704]
11:41:16 INFO - #05: mozilla::layers::LayerManagerComposite::EndTransaction(void (*)(mozilla::layers::PaintedLayer *,gfxContext *,nsIntRegion const &,mozilla::layers::DrawRegionClip,nsIntRegion const &,void *),void *,mozilla::layers::LayerManager::EndTransactionFlags) [gfx/layers/composite/LayerManagerComposite.cpp:311]
11:41:16 INFO - #06: mozilla::layers::LayerManagerComposite::EndEmptyTransaction(mozilla::layers::LayerManager::EndTransactionFlags) [gfx/layers/composite/LayerManagerComposite.cpp:257]
11:41:16 INFO - #07: mozilla::layers::CompositorParent::CompositeCallback(mozilla::TimeStamp) [gfx/layers/ipc/CompositorParent.cpp:829]
11:41:16 INFO - #08: RunnableMethod<mozilla::layers::CompositorParent,void ( mozilla::layers::CompositorParent::*)(mozilla::TimeStamp),Tuple1<mozilla::TimeStamp> >::Run() [ipc/chromium/src/base/task.h:308]
11:41:16 INFO - #09: MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const &) [ipc/chromium/src/base/message_loop.cc:372]
11:41:16 INFO - #10: MessageLoop::DoWork() [ipc/chromium/src/base/message_loop.cc:447]
11:41:16 INFO - #11: base::MessagePumpForUI::DoRunLoop() [ipc/chromium/src/base/message_pump_win.cc:217]
11:41:16 INFO - #12: base::MessagePumpWin::Run(base::MessagePump::Delegate *) [ipc/chromium/src/base/message_pump_win.h:78]
11:41:16 INFO - #13: MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:233]
11:41:16 INFO - #14: MessageLoop::RunHandler() [ipc/chromium/src/base/message_loop.cc:227]
11:41:16 INFO - #15: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:201]
11:41:16 INFO - #16: base::Thread::ThreadMain() [ipc/chromium/src/base/thread.cc:173]
11:41:16 INFO - #17: `anonymous namespace'::ThreadFunc(void *) [ipc/chromium/src/base/platform_thread_win.cc:27]
11:41:16 INFO - #18: kernel32 + 0x53c45
11:41:16 INFO - #19: ntdll + 0x637f5
11:41:16 INFO - #20: ntdll + 0x637c8
11:41:18 INFO - TEST-INFO | Main app process: exit status 1 

11:41:29 WARNING - PROCESS-CRASH | browser/components/preferences/in-content/tests/browser_privacypane_1.js | application crashed [@ mozilla::layers::CompositorD3D11::HandleError(long,mozilla::layers::CompositorD3D11::Severity)]
11:41:29 INFO - Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpaxeby4.mozrunner\minidumps\f2b36dca-bd76-4422-bf1c-32784f269c84.dmp
11:41:29 INFO - Operating system: Windows NT
11:41:29 INFO - 6.1.7601 Service Pack 1
11:41:29 INFO - CPU: x86
11:41:29 INFO - GenuineIntel family 6 model 30 stepping 5
11:41:29 INFO - 8 CPUs
11:41:29 INFO - Crash reason: EXCEPTION_BREAKPOINT
11:41:29 INFO - Crash address: 0x60147d54
11:41:29 INFO - Thread 34 (crashed)
11:41:29 INFO - 0 xul.dll!mozilla::layers::CompositorD3D11::HandleError(long,mozilla::layers::CompositorD3D11::Severity) [CompositorD3D11.cpp:5cdd3215addc : 1425 + 0x1d]
11:41:29 INFO - eip = 0x60147d54 esp = 0x0fadf568 ebp = 0x0fadf568 ebx = 0x0dc1f9c0
11:41:29 INFO - esi = 0x0dc1f9c0 edi = 0x00000000 eax = 0x00000000 ecx = 0x68520ad9
11:41:29 INFO - edx = 0x0030c911 efl = 0x00000212
11:41:29 INFO - Found by: given as instruction pointer in context
11:41:29 INFO - 1 xul.dll!mozilla::layers::CompositorD3D11::VerifyBufferSize() [CompositorD3D11.cpp:5cdd3215addc : 1220 + 0x9]
11:41:29 INFO - eip = 0x60149247 esp = 0x0fadf570 ebp = 0x0fadf5c0
11:41:29 INFO - Found by: call frame info
11:41:29 INFO - 2 xul.dll!mozilla::layers::CompositorD3D11::UpdateRenderTarget() [CompositorD3D11.cpp:5cdd3215addc : 1228 + 0x6]
11:41:29 INFO - eip = 0x601490c1 esp = 0x0fadf5c8 ebp = 0x0fadf5e0
11:41:29 INFO - Found by: call frame info
11:41:29 INFO - 3 xul.dll!mozilla::layers::CompositorD3D11::BeginFrame(nsIntRegion const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const *,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> *,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> *) [CompositorD3D11.cpp:5cdd3215addc : 1053 + 0x6]
11:41:29 INFO - eip = 0x60145d05 esp = 0x0fadf5e8 ebp = 0x0fadf670
11:41:29 INFO - Found by: call frame info
11:41:29 INFO - 4 xul.dll!mozilla::layers::LayerManagerComposite::Render() [LayerManagerComposite.cpp:5cdd3215addc : 703 + 0xa]
11:41:29 INFO - eip = 0x601ab880 esp = 0x0fadf678 ebp = 0x0fadf884
11:41:29 INFO - Found by: call frame info
11:41:29 INFO - 5 xul.dll!mozilla::layers::LayerManagerComposite::EndTransaction(void (*)(mozilla::layers::PaintedLayer *,gfxContext *,nsIntRegion const &,mozilla::layers::DrawRegionClip,nsIntRegion const &,void *),void *,mozilla::layers::LayerManager::EndTransactionFlags) [LayerManagerComposite.cpp:5cdd3215addc : 309 + 0x6]
11:41:29 INFO - eip = 0x601a7536 esp = 0x0fadf88c ebp = 0x0fadf904
11:41:29 INFO - Found by: call frame info
11:41:29 INFO - 6 xul.dll!mozilla::layers::LayerManagerComposite::EndEmptyTransaction(mozilla::layers::LayerManager::EndTransactionFlags) [LayerManagerComposite.cpp:5cdd3215addc : 256 + 0x9]
11:41:29 INFO - eip = 0x601a7343 esp = 0x0fadf90c ebp = 0x0fadf9a8
11:41:29 INFO - Found by: call frame info
11:41:29 INFO - 7 xul.dll!mozilla::layers::CompositorParent::CompositeToTarget(mozilla::gfx::DrawTarget *,nsIntRect const *) [CompositorParent.cpp:5cdd3215addc : 914 + 0xb]
11:41:29 INFO - eip = 0x601be627 esp = 0x0fadf920 ebp = 0x0fadf9a8
11:41:29 INFO - Found by: call frame info
11:41:29 INFO - 8 xul.dll!mozilla::layers::CompositorParent::CompositeCallback(mozilla::TimeStamp) [CompositorParent.cpp:5cdd3215addc : 829 + 0xe]
11:41:29 INFO - eip = 0x601be459 esp = 0x0fadf9b0 ebp = 0x0fadf9dc
11:41:29 INFO - Found by: call frame info
11:41:29 INFO - 9 xul.dll!RunnableMethod<mozilla::layers::CompositorParent,void ( mozilla::layers::CompositorParent::*)(mozilla::TimeStamp),Tuple1<mozilla::TimeStamp> >::Run() [task.h:5cdd3215addc : 307 + 0x17]
11:41:29 INFO - eip = 0x601c7f82 esp = 0x0fadf9e4 ebp = 0x0fadfa24
11:41:29 INFO - Found by: call frame info
11:41:29 INFO - 10 xul.dll!MessageLoop::RunTask(Task *) [message_loop.cc:5cdd3215addc : 361 + 0xd]
11:41:29 INFO - eip = 0x5fc11a86 esp = 0x0fadfa0c ebp = 0x0fadfa24
11:41:29 INFO - Found by: call frame info
Comment hidden (Legacy TBPL/Treeherder Robot)
Bug 1107718 should take care of this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1107718
(In reply to Milan Sreckovic [:milan] from comment #2)
> Bug 1107718 should take care of this.
> 
> *** This bug has been marked as a duplicate of bug 1107718 ***

I don't think it will always do so in debug builds. In those situations we might still assert, we won't crash in release builds anymore though. But I'm not certain.
So, should we unduplicate this bug?
You need to log in before you can comment on or make changes to this bug.