[Flame][Gallery]5 option icons will be displayed after sliding progress bar while video is playing.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Gallery
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Alissa(leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 wontfix, b2g-v2.1S wontfix, b2g-v2.2 unaffected)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8545128 [details]
2.png

[1.Description]:
[Flame][v2.1&2.2][Gallery]Playing a video in Gallery,sometimes we want to drag progress bar forward or backward. After we do this operation, 5 option icons appear at bottom of screen unexpectedly.
Occurence time:18:59
see attachments:logcat.txt,659.3gp,figure 2.png

[2.Testing Steps]: 
1.Launch Gallery.
2.Play a video.
3.Try to slide the playing progress bar.

[3.Expected Result]: 
3.The option icons should not be displayed while video is playing .

[4.Actual Result]: 
3-1. Sometimes,5 option icons appear at the bottom of screen.
3-2. Besides,sometimes the Edit icon is usable,sometimes it is disabled.
3-3. If the Edit icon is usable,we can edit this video and save as image.[2.png]

[5.Reproduction build]: 
FLame 2.1 build:
Gaia-Rev        b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko-Rev     https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/99cea2c818f6
Build-ID           20150106001308
Version           34.0

Flame 2.2 build:
Gaia-Rev        b77e0d56d197e0ee02d801a25c784130d888c9db
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2a193b7f395c
Build-ID        20150106010234
Version         37.0a1

[6.Reproduction Frequency]: 
occasionally Recurrence,5/60

[7.TCID]:
 Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8545129 [details]
logcat.txt
(Reporter)

Comment 2

3 years ago
Created attachment 8545133 [details]
659.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Edge case, not easy to reproduce, but cc RD.
(Reporter)

Comment 4

3 years ago
Hi mike, it is easy to reproduce this issue on v2.1[5/8], v2.1s[1/10], but I cannot reproduce it on v2.2 and 3.0. Could you please help to check wheater this issue need to be fixed on 2.1?

Device:Flame2.1[Affected]
Build ID               20150607001204
Gaia Revision          2304a1f6327c2ccf35d6995ee16f2231ed1f22a3
Gaia Date              2015-05-26 13:30:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebbace93b522
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150607.035246
Firmware Date          Sun Jun  7 03:52:57 EDT 2015
Bootloader             L1TC000118D0

Device:2.1S[Affected]
Gaia-Rev        e29043077da834854bfda9d409d1e690fb8070c3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/cfb14ccd1e22
Build-ID        20150607001205
Version         34.0
Device-Name     scx15_sp7715ea
FW-Release      4.4.2
FW-Incremental  122
FW-Date         Thu Feb  5 12:42:58 CST 201

Device: Flame 2.2[Unaffected]
Build ID               20150607002503
Gaia Revision          8fc797527a3eca7665bc1d1828848f2fb77ca99f
Gaia Date              2015-06-04 07:46:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d213237e11e9
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150607.035848
Firmware Date          Sun Jun  7 03:58:59 EDT 2015
Bootloader             L1TC000118D0

Device:Flame 3.0[Unaffected]
Build ID               20150607160204
Gaia Revision          1d62b32408567f9f7cf1c71c1e5a0c6593be757b
Gaia Date              2015-06-05 17:55:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7d4ab4a9febd
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150607.193246
Firmware Date          Sun Jun  7 19:32:58 EDT 2015
Bootloader             L1TC000118D0
status-b2g-v2.1S: --- → affected
Flags: needinfo?(mlien)

Comment 5

3 years ago
v2.1 won't fix on this time

Hi Steven, do you think v2.1S should resolve this problem?
Flags: needinfo?(mlien) → needinfo?(styang)
I'm okay not to fix it on 2.1S. thanks.
Flags: needinfo?(styang)

Comment 7

3 years ago
From comment 4~comment 6, wontfix this issue
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.1: affected → wontfix
status-b2g-v2.1S: affected → wontfix
status-b2g-v2.2: affected → unaffected
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.