[Flame][Settings]The "Uninstall App" button under system AP is available in App Permissions.

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: liuyong, Assigned: arthurcc)

Tracking

({regression})

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

Reporter

Description

5 years ago
Posted video uninstall_Button.MP4
[1.Description]:
[Flame][2.2][Settings]In "App Permissions", tap into a certain app(eg:Browser,Camera),check the button, you'll find the "Uninstall app" is active.

Attachments: logcat_0402.txt,uninstall_Button.mp4
Found time:0402

[2.Testing Steps]: 
1. Launch Settings->"App Permissions".
2. Tap one App(eg:Browser,Camera).
3. Check the "Uninstall App" button.

Note: The Ap still exists after uninstalling it.

[3.Expected Result]: 
3. The "Uninstall App" button should be gray.

[4.Actual Result]: 
3. The "Uninstall App" button is available.

[5.Reproduction build]: 
Gaia-Rev        b77e0d56d197e0ee02d801a25c784130d888c9db
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2a193b7f395c
Build-ID        20150106010234
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150106.043413
FW-Date         Tue Jan  6 04:34:26 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Comment 1

5 years ago
Posted file logcat_0402.txt
These cannot be uninstalled by user, because these are built-in apps(for debug build).
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Reporter

Comment 3

5 years ago
Hi Eric,
    This issue means that the "Uninstall App " button should be unavailable about built-in apps, doesn't mean uninstall the built-in apps.I check it on Flame 2.1, "Uninstall App" button is gary in "App Permissions".
    Can you check again? Thanks.
Flags: needinfo?(echang)
So set 2.2? for regression, thanks.
Status: RESOLVED → REOPENED
blocking-b2g: --- → 2.2?
Keywords: regression
Resolution: INVALID → ---
Flags: needinfo?(echang)

Comment 5

4 years ago
Triage; regression, blocking
Assignee: nobody → arthur.chen
blocking-b2g: 2.2? → 2.2+
Status: REOPENED → ASSIGNED
It would be preferable if we could find the window.
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20141121114318
Gaia: b000ab0dc6fd59ae037e9553d8e09de4ee69fdc4
Gecko: c10f54c61a12
Version: 36.0a1 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20141121120915
Gaia: c5bad6d78c5fe168e3bb894fc5cb70902c9b19b1
Gecko: b612d5a501f8
Version: 36.0a1 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: b000ab0dc6fd59ae037e9553d8e09de4ee69fdc4
Gecko: b612d5a501f8

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: c5bad6d78c5fe168e3bb894fc5cb70902c9b19b1
Gecko: c10f54c61a12

https://github.com/mozilla-b2g/gaia/compare/b000ab0dc6fd59ae037e9553d8e09de4ee69fdc4...c5bad6d78c5fe168e3bb894fc5cb70902c9b19b1

caused by bug 1053954
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Arnau, can you take a look at this please? This might have been caused by the landing for bug 1053954.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(rnowmrch)
Comment on attachment 8558895 [details] [review]
[PullReq] crh0716:1118671 to mozilla-b2g:master

EJ, could you review this simple patch? I correct the selector and remove the text from the html file at the same time.
Flags: needinfo?(rnowmrch)
Attachment #8558895 - Flags: review?(ejchen)
Comment on attachment 8558895 [details] [review]
[PullReq] crh0716:1118671 to mozilla-b2g:master

Thanks Arthur, this patch looks nice to me, r+

:)
Attachment #8558895 - Flags: review?(ejchen) → review+
Thanks, EJ!

master: ab4cd80140e9fdf347efb32e01f62b222727ab57
Status: ASSIGNED → RESOLVED
Closed: 5 years ago4 years ago
Resolution: --- → FIXED
Comment on attachment 8558895 [details] [review]
[PullReq] crh0716:1118671 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1053954
[User impact] if declined: Users are able to click the remove button of system apps although the operation would fail.
[Testing completed]: Testing on the device
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: None
Attachment #8558895 - Flags: approval-gaia-v2.2?
The patch simply correct the CSS selector and should be no risk.
Attachment #8558895 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Reporter

Comment 16

4 years ago
This issue has been verified successfully on Flame 2.2.
Reproduce rate:0/5.

Flame2.2 build:

Gaia-Rev        791e53728cd8018f1d7cf7efe06bbeb1179f0370
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5dec207fcbeb
Build-ID        20150212002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150212.042208
FW-Date         Thu Feb 12 04:22:18 EST 2015
Bootloader      L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+],[MGSEI-Triage+]
Reporter

Comment 17

4 years ago
(In reply to Coler from comment #16)
> This issue has been verified successfully on Flame 2.2.
Update  Flame 2.2 build:

Build ID               20150214002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6de30e6bbc84
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.044811
Firmware Date          Sat Feb 14 04:48:22 EST 2015
Bootloader             L1TC000118D0
Reporter

Comment 18

4 years ago
This issue has been verified successfully on Flame 3.0.

Flame3.0 build:

Build ID               20150225160227
Gaia Revision          cc235a867161e0000ea55a4f009b3be19021f066
Gaia Date              2015-02-25 05:01:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6608e0605dfc
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.192909
Firmware Date          Wed Feb 25 19:29:21 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.