When switching between month, week, and day view, the blue underline spazzes

RESOLVED FIXED

Status

Firefox OS
Gaia::Calendar
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: gaye, Unassigned)

Tracking

({polish})

unspecified
x86_64
Linux
polish

Firefox Tracking Flags

(blocking-b2g:-, tracking-b2g:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
We use a little blue line to help indicate which view is currently being shown. When you switch between views, switching the tab which is underlined looks really bad. There's always a period when multiple things are underlined. Transitions would feel nicer if we could fix this and should be low effort.
(Reporter)

Updated

3 years ago
blocking-b2g: --- → 2.2?
tracking+ for polish

One easy way to reproduce this condition is to double-tap a day in month view. It will zoom into day view with both month and day tabs highlighted.
blocking-b2g: 2.2? → -
tracking-b2g: --- → +
Keywords: polish
we have plans to change the double tap behavior on the month view to create an event instead of moving to the day view (Bug 1037351)
See Also: → bug 1037351
(Reporter)

Comment 3

3 years ago
Created attachment 8549168 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27392

Seems to fix tab lag
Attachment #8549168 - Flags: review?(mmedeiros)
this is in fact a duplicate of Bug 1021445
Attachment #8549168 - Flags: review?(mmedeiros) → review+
(Reporter)

Comment 5

3 years ago
Landed on master https://github.com/mozilla-b2g/gaia/commit/7da5aa3c52f0d8949afe389869cf507315e6e268
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.