Sync button looks too similar to all day event icon

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Calendar
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: gaye, Assigned: gmarty)

Tracking

({polish})

unspecified
2.2 S7 (6mar)
x86_64
Linux
polish

Firefox Tracking Flags

(blocking-b2g:-, tracking-b2g:backlog, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Our productivity apps teach users that when you click the arc with an arrow at the end, sync happens. The 24 hour icon breaks this rule and we should replace it with something that won't confuse people.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → -
tracking-b2g: --- → ?
Whiteboard: polish
Created attachment 8554357 [details]
calendar_2.2_allday_icon_07.png

Hi all

Please see attached file for new all day event icon preview.
If is ok I will provide image later.
Can you tell me what kind of format should I give? png or svg?
Thanks!

Updated

3 years ago
Keywords: polish
Whiteboard: polish

Comment 2

3 years ago
(In reply to Peko Chen [:peko] from comment #1)
> Created attachment 8554357 [details]
> calendar_2.2_allday_icon_07.png
> 
> Hi all
> 
> Please see attached file for new all day event icon preview.
> If is ok I will provide image later.
> Can you tell me what kind of format should I give? png or svg?
> Thanks!

We need an svg for this icon, it gets put inside a font - here's the current one: https://github.com/wilsonpage/gaia-icons/blob/master/images/all-day.svg
Flags: needinfo?(pchen)
Created attachment 8568414 [details]
icon_allday.svg

Hi,
Please see attached file for new all day event icon.
Thank you.
Flags: needinfo?(pchen)

Updated

3 years ago
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Assignee: chrislord.net → gmarty
Created attachment 8568619 [details] [review]
[gaia] gmarty:Bug-1118861-Sync-button-looks-too-similar-to-all-day-event-icon > mozilla-b2g:master
(Assignee)

Comment 5

3 years ago
Comment on attachment 8568619 [details] [review]
[gaia] gmarty:Bug-1118861-Sync-button-looks-too-similar-to-all-day-event-icon > mozilla-b2g:master

This patch contains an update of gaia-icons and replaces the all day icon by the new one.
Gareth, can you have a look?
Attachment #8568619 - Flags: review?(gaye)
Comment on attachment 8568619 [details] [review]
[gaia] gmarty:Bug-1118861-Sync-button-looks-too-similar-to-all-day-event-icon > mozilla-b2g:master

Bouncing review over to Miller.
Attachment #8568619 - Flags: review?(gaye) → review?(mmedeiros)
Comment on attachment 8568619 [details] [review]
[gaia] gmarty:Bug-1118861-Sync-button-looks-too-similar-to-all-day-event-icon > mozilla-b2g:master

added some comments on github. PR needs a couple changes before we can merge it.
Flags: needinfo?(gmarty)
(Assignee)

Comment 8

3 years ago
Comment on attachment 8568619 [details] [review]
[gaia] gmarty:Bug-1118861-Sync-button-looks-too-similar-to-all-day-event-icon > mozilla-b2g:master

I've updated the patch to integrate your comments. I also removed some unused CSS. How does it look now?
Flags: needinfo?(gmarty)
Comment on attachment 8568619 [details] [review]
[gaia] gmarty:Bug-1118861-Sync-button-looks-too-similar-to-all-day-event-icon > mozilla-b2g:master

Thanks!
Attachment #8568619 - Flags: review?(mmedeiros) → review+
(Assignee)

Comment 10

3 years ago
Landed in master in https://github.com/mozilla-b2g/gaia/commit/3f2003f6deb5ee642fd3a0a361e5bfe0f7cf28f6
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Want to request uplift on this? Tiny change for a little bit of polish, basically zero risk.
Flags: needinfo?(gmarty)
(Assignee)

Comment 12

3 years ago
Comment on attachment 8568619 [details] [review]
[gaia] gmarty:Bug-1118861-Sync-button-looks-too-similar-to-all-day-event-icon > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Calendar app
[User impact] if declined: The 24 hour icon looks like a refresh icon.
[Testing completed]: Manual testing.
[Risk to taking this patch] (and alternatives if risky): Low impact as it's a polish bug that mainly changes some markup and CSS.
[String changes made]: None
Flags: needinfo?(gmarty)
Attachment #8568619 - Flags: approval-gaia-v2.2?(bbajaj)
Comment on attachment 8568619 [details] [review]
[gaia] gmarty:Bug-1118861-Sync-button-looks-too-similar-to-all-day-event-icon > mozilla-b2g:master

approving given the super low risk here.
Attachment #8568619 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/9163e570cb6310c17df63311424fb50305cd4815
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S7 (6mar)
Whiteboard: [systemsfe]
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The calander app now uses a newer icon that is less similar to the sync icon.

Environmental Variables:
Device: Flame 3.0 KK (319MB) (Full Flash)
BuildID: 20150313010238
Gaia: eabe35cf054d47087b37c1ca7db8143717fbd7f3
Gecko: 42afc7ef5ccb
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319MB) (Full Flash)
BuildID: 20150313002507
Gaia: 4aefc3f6f30a40ac67fdf841b7c90cd648b85369
Gecko: 049713f3b0ed
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.