20% slowdown on non-odin asmjs-ubench-skinning on 32-bit awfy, around PJS removal

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: azakai, Unassigned)

Tracking

24 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Comment 1

4 years ago
If the PJS removal is the source of the regression then the regression is almost certainly caused by perturbations in object code for the GC, since a bunch of GC code that was previously active on Nightly - in the form of checks for whether the nursery was the ForkJoin nursery, and some functions defined on multiple nursery types - no longer is.  In particular I could imagine some functions that were previously not inlinable due to size or complexity becoming inlinable after these patches landed.
Blocks: 1117724
(Reporter)

Comment 2

4 years ago
Looks like the regression went back down with the landing of bug 1118038. It does sound like some kind of minor perturbations, I guess we can close this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.