If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New AOL Repack Configuration for Firefox 35 - AOL Desktop

RESOLVED FIXED

Status

Release Engineering
Releases: Custom Builds
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: brian ellis, Assigned: mixedpuppy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8545473 [details] [diff] [review]
repack_config_changes_for_AOL_Desktop for FF35

This is a request for a new custom browser for AOL.  AOL Desktop.  I have included the diff file that contains all of the new changes.  In the past when I requested a new custom browser, I did using a form provided.  This is the first time with bugzilla.  The AOL Desktop custom browser will have the same features as the AOL, AOLDE and AOLUK custom browsers.  

The browser search is defined in aol_desktop/distribution/searchplugins/common/aol-search.xml.

The toolbar bookmarks is defined in aol_desktop/distribution/distribution.ini.

The toolbar extension contains the following buttons and urls:

AIM	http://www.aim.com/?icid=admffx_toolbar_aim
News	http://www.aol.com/news/?icid=admffx_toolbar_news
Finance	http://www.aol.com/finance/?icid=admffx_toolbar_finance
Music	http://aolradio.slacker.com/?icid=admffx_toolbar_music
TV	http://www.huffingtonpost.com/tv/?icid=admffx_toolbar_television
Movies	http://www.moviefone.com/?icid=admffx_toolbar_movies
People	http://lifestream.aol.com/?icid=admffx_toolbar_people
Living	http://www.stylelist.com/?icid=admffx_toolbar_living
Sports	http://www.aol.com/sports/?icid=admffx_toolbar_sports
MapQuest http://www.mapquest.com/?icid=admffx_toolbar_mapquest

There is a mail widget also included on the toolbar.

The startpage is defined in aol_desktop/distribution/distribution.ini

The browser address bar search is defined in aol_desktop/distribution/distribution.ini

I know this is within the two week window before FF35 is released but if a build can be delivered that I can test with soon, that would be great.

Please let me know if there is anything that I missed or need to elaborate on something.

thanks,
Brian Ellis
(Reporter)

Comment 1

3 years ago
Comment on attachment 8545473 [details] [diff] [review]
repack_config_changes_for_AOL_Desktop for FF35

ready for review
Attachment #8545473 - Flags: review?
(Assignee)

Comment 2

3 years ago
I extracted and diff'd "aol_desktop" against the "aol" distribution and am ok the pertinent changes as you outlined.

It seems most of the diff is changing "aol" -> "aoldesktop", seems like a lot of effort for maintenance in order to just have a few different urls in the toolbar.
(Assignee)

Updated

3 years ago
Attachment #8545473 - Flags: review? → review+
(Assignee)

Comment 3

3 years ago
Mike, anything we need to do to add new distributions (other than pushing the patch)?
Flags: needinfo?(mconnor)
(Assignee)

Comment 4

3 years ago
https://hg.mozilla.org/build/partner-repacks/rev/b237f3da7705
(Reporter)

Comment 5

3 years ago
Hi,  I just want to be clear that this is a request for an additional custom browser (to go with the AOL, AOL UK and AOL DE browsers).

thanks, 
Brian Ellis
If it's there it will be built.
Flags: needinfo?(mconnor)
(Assignee)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

3 years ago
Hi - I just checked the AOL desktop custom browser built today and I notifed that the startup homepage welcom url was displayed when the browser opened for the first time.  I defined the url (http://discover.aol.com/post-install-mac) for the startup.homepage_welcome_url in the distribution.ini file.  Is there somewhere else that this needs to be defined?
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Assignee)

Comment 8

3 years ago
(In reply to brian ellis from comment #7)
> Hi - I just checked the AOL desktop custom browser built today and I notifed
> that the startup homepage welcom url was displayed when the browser opened
> for the first time.  I defined the url
> (http://discover.aol.com/post-install-mac) for the
> startup.homepage_welcome_url in the distribution.ini file.  Is there
> somewhere else that this needs to be defined?

I'm not really clear on what you're saying the problem is, is your url not appearing on startup?  Also, that url leads me to a "not found" page on aol.
(Assignee)

Updated

3 years ago
Flags: needinfo?(brian.ellis)
(Reporter)

Comment 9

3 years ago
Right that url isn't live yet, so it will not render now.  That is correct, the url is supposed to be the onetime startup url.
Flags: needinfo?(brian.ellis)
(Reporter)

Comment 10

3 years ago
I think I figured out how to fix this (the congrats page issue).  The toolbar upon successful install will launch a congrats page, so that is appearing after the default browser congrats page is loaded.  I have updated the toolbar so that option is turned off (i.e. no congrats page will be launched after toolbar install).  The only other change is that the toolbar version number has been upped:

-  <em:version>5.224.1.10274</em:version>
+  <em:version>5.224.1.10276</em:version>

The repack diff has been attached.
(Reporter)

Comment 11

3 years ago
Created attachment 8548973 [details] [diff] [review]
repack_config_changes_for_AOLDesktop.diff

The toolbar will not display the congrats page after toolbar install.  The toolbar version number has been upped:

-  <em:version>5.224.1.10274</em:version>
+  <em:version>5.224.1.10276</em:version>
Attachment #8545473 - Attachment is obsolete: true
Attachment #8548973 - Flags: review?

Updated

3 years ago
Attachment #8548973 - Flags: review? → review?(mixedpuppy)

Updated

3 years ago
Assignee: nobody → mixedpuppy
(Assignee)

Comment 12

3 years ago
Comment on attachment 8548973 [details] [diff] [review]
repack_config_changes_for_AOLDesktop.diff

https://hg.mozilla.org/build/partner-repacks/rev/c081fa95ccb1
Attachment #8548973 - Flags: review?(mixedpuppy) → review+
(Assignee)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.