[Messages][Subject] Focus is not given to the subject area of a message when adding a subject to the message

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::SMS
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: DerekH, Assigned: azasypkin)

Tracking

({regression})

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-Daily-Testing][sms-sprint-2.2S4], URL)

Attachments

(2 attachments)

Created attachment 8545513 [details]
Subject in Messages Logcat

Description:
The user can add the subject area to a message, but when it is first added the subject area of the message is not given focus. The keyboard does not appear, and the cursor is absent. It is not immediately obvious to the user where the subject area is located

Repro Steps:
1) Update a Flame to 20150107010216
2) Open Messages App
3) Open a new or existing thread
4) Tap on the "..." in the upper right corner
5) Select "Add Subject"


Actual:
The focus is taken away from typing and is given to the thread


Expected:
The focus is given to the subject section of the message

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150107010216
Gaia: 69ac77cfa938fae2763ac426a80ca6e5feb6ad25
Gecko: 33781a3a5201
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 10/10 100%
See attached: Logcat, Video - https://www.youtube.com/watch?v=Rn4hBgrcL6s&edit=vd
This issue does NOT occur in Flame 2.1

The Subject area of the message is properly brought into focus

Device: Flame 2.1
BuildID: 20150107001244
Gaia: b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko: 99cea2c818f6
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 34.0 (2.1)
Firmware: V18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
blocking-b2g: --- → 2.2?
Keywords: regressionwindow-wanted
Triage: Regression.
blocking-b2g: 2.2? → 2.2+
QA Contact: jmercado
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Bug 1078295 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141015070318
Gaia: a18559e844b6aec946309a3bee6a32ca06ab4649
Gecko: fe4916e0e9df
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141015102818
Gaia: 93fb5070782a549977cf8c485c5d93de54ec657e
Gecko: 069db53e0f68
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: a18559e844b6aec946309a3bee6a32ca06ab4649
Gecko: 069db53e0f68

First Broken gaia / Last Working gecko - 
Gaia: 93fb5070782a549977cf8c485c5d93de54ec657e
Gecko: fe4916e0e9df

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/a18559e844b6aec946309a3bee6a32ca06ab4649...93fb5070782a549977cf8c485c5d93de54ec657e
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Chris, can you please take a look at this issue? Looks like the uplift for bug 1078295 caused this issue.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(chrislord.net)
If Chris can't take it, we'll take it in the next sprint.

Comment 6

3 years ago
I'm pretty inundated with bugs I need to tackle this week (and likely next), going on comment #5, I'm going to defer this. If this is still an issue in a couple of weeks, n? me again and I should hopefully be a bit less swamped at that point.
Flags: needinfo?(chrislord.net)
(Assignee)

Comment 7

3 years ago
No worries Chris, I'll see what's happening here.
Flags: needinfo?(azasypkin)
(Assignee)

Updated

3 years ago
Assignee: nobody → azasypkin
Status: NEW → ASSIGNED
Flags: needinfo?(azasypkin)
(Assignee)

Comment 8

3 years ago
Created attachment 8550269 [details] [review]
GitHub pull request URL

Possible root cause is discussed in bug 1122463. I don't ask for review until we have more details in bug 1122463.
(Assignee)

Updated

3 years ago
Depends on: 1122463
(Assignee)

Comment 9

3 years ago
Comment on attachment 8550269 [details] [review]
GitHub pull request URL

Hey Steve, here is small patch that changes OptionMenu item button type from "submit" to "button". I've played with Messages and other apps that use OptionMenu and haven't noticed any side effects.

+ added integration test to eliminate future regressions.

I'd say think we can proceed with this change to not be blocked by bug 1122463. What do you think?
Attachment #8550269 - Flags: review?(schung)
Ah, please note that "Composer" integration tests are currently disabled on Treeherder (see bug 1121766).
Comment on attachment 8550269 [details] [review]
GitHub pull request URL

Thanks for the fixing!

> I'd say think we can proceed with this change to not be blocked by bug 1122463. What do you think?

I agree. Even bug 1122463 is landed, it's still safer to use 'button' instead of 'submit'
Attachment #8550269 - Flags: review?(schung) → review+

Updated

3 years ago
No longer depends on: 1122463
Whiteboard: [2.2-Daily-Testing] → [2.2-Daily-Testing][sms-sprint-2.2S4]
Comment on attachment 8550269 [details] [review]
GitHub pull request URL

Hey Kevin,

Here's a small change in OptionMenu from shared folder that resolves the issue we see in this bug.

Could you please help to review it?

Thanks!
Attachment #8550269 - Flags: review?(kgrandon)
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1124097
Comment on attachment 8550269 [details] [review]
GitHub pull request URL

The shared/ changes seem fine to me. Thanks!
Attachment #8550269 - Flags: review?(kgrandon) → review+
Thanks for review guys! Treeherder is green, so landed.

Master: https://github.com/mozilla-b2g/gaia/commit/63c6bc1db32854f319fe292f9496463f4584b5a2
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Comment on attachment 8550269 [details] [review]
GitHub pull request URL

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): essentially bug 1057898
[User impact] if declined: when user adds subject from "..." menu it won't be automatically focused, when user removes subject from "..." menu - message input won't be automatically focused.
[Testing completed]: yes, manual, unit and integration test
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8550269 - Flags: approval-gaia-v2.2?
Comment on attachment 8550269 [details] [review]
GitHub pull request URL

Thanks for the tests!
Attachment #8550269 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/ee77573a37433b1a30655f925158c612e5f446e5
status-b2g-v2.2: affected → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S4 (23jan)
This issue is verified fixed on the latest Flame 3.0 and Flame 2.2 builds.

Actual Results:  The subject is given focus after adding it.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150203055641
Gaia: ae5a1580da948c3b9f93528146b007fc4f6a712b
Gecko: ae5d04409cd9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Environmental Variables:
Device: Flame 2.2
BuildID: 20150203002504
Gaia: cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gecko: 11d93135c678
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Oleg, would you like to push an updated patch now the that bug 1122463 is finally fixed?
Flags: needinfo?(azasypkin)
(In reply to Tim Guan-tin Chien [:timdream] (slow response; please ni? to queue) from comment #20)
> Oleg, would you like to push an updated patch now the that bug 1122463 is
> finally fixed?

Hey Tim, thanks for the fix in bug 1122463!

I think we don't need to update previous patch - we just set "button" type (so there is no "submit" event on button click) for all buttons in OptionMenu that sounds reasonable anyway.
Flags: needinfo?(azasypkin)
You need to log in before you can comment on or make changes to this bug.