Closed Bug 1119090 Opened 5 years ago Closed 5 years ago

B2G RIL: There is no missed call information when receive a missed call during active call.

Categories

(Firefox OS Graveyard :: RIL, defect, P2)

defect

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 unaffected, b2g-v2.0M verified, b2g-v2.1 unaffected, b2g-v2.2 verified)

VERIFIED FIXED
2.2 S3 (9jan)
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.0M --- verified
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified

People

(Reporter: sku, Assigned: sku)

References

Details

Attachments

(3 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1116642 +++

My phone number is 13539427331
 DEFECT DESCRIPTION:
 >ko:There is no missed call icon on status bar and the missed call become an outgoing call on call log.
 
  REPRODUCING PROCEDURES:
 Make a active call -> during the call, make a mised call -> end the active call -> ko
 
  EXPECTED BEHAVIOUR:
 MS should display the missed call on status bar and call log.
 
 >61336
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:100%
 
  For FT PR, Please list reference mobile's behavior:
Assignee: nobody → sku
Attachment #8545623 - Flags: review?(htsai)
blocking-b2g: --- → 2.0M?
Duplicate of this bug: 1116642
root cause: "isOutgoing":true is wrong cause this call is a MT one.
we cannot only check "!(newCall.state == CALL_STATE_INCOMING);" at [1] because there still have waiting type we need to care.

12-27 16:38:39.998   161   161 I Gecko   : TelephonyService: handleCallDisconnected: {"state":5,"callIndex":2,"toa":129,"isMpty":false,"isMT":true,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"13539427331","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false,"failCause":"NormalCallClearingError"}


[1] - https://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_worker.js?from=ril_worker.js&case=true#4113
Comment on attachment 8545623 [details] [diff] [review]
Bug 1119090 - B2G RIL: There is no missed call information when receive a missed call during active call.

Review of attachment 8545623 [details] [diff] [review]:
-----------------------------------------------------------------

Since Hsinyi is OOO, re-direct review to aknow.
Attachment #8545623 - Flags: review?(htsai) → review?(szchen)
Attachment #8545623 - Flags: review?(szchen) → review+
No longer depends on: 1116642
https://hg.mozilla.org/mozilla-central/rev/fa7a1beefeb9
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S3 (9jan)
Hi Kai-Zhen,
2.0M+ Thanks!
blocking-b2g: 2.0M? → 2.0M+
Flags: needinfo?(kli)
Blocks: 1080481
Attached video woodduck 2.0m video
This problem is verified pass on latest build of woodduck2.0 and Flame2.2
See attachments: woodduck_2.0m_video.mp4
Rate: 0/3

Woodduck 2.0 build:
Gaia-Rev        ddb406ebdb34ca6717eda14297dea98f26f1f412
Gecko-Rev       20943fe7b54c63a375952fbd8dd396a22ee893e7
Build-ID        20150114050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1421183152
FW-Date         Wed Jan 14 05:06:17 CST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150113162504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150113.194114
FW-Date         Tue Jan 13 19:41:25 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.