document drag animation bring machine to crawl over remote X session

VERIFIED DUPLICATE of bug 86138

Status

()

Core
Drag and Drop
--
minor
VERIFIED DUPLICATE of bug 86138
16 years ago
16 years ago

People

(Reporter: jeff, Assigned: Paul Chen)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011124
BuildID:    0.9.6

I'm able to run Mozilla mostly fine using a remote X session tunnelled 
through ssh. Both the local and remote machine are running Debian
Sid with XFree86 4.1.0. The slowest part of the network is probably
a 150 kilobyte/sec DSL link.

If I highlight a word on any HTML page (any word, not a hyperlink) 
and then do a drag operation with the mouse (to some other part of the
page) a cute animation appears where there is an icon of a document
moves around then "snaps back" into place when the mouse is released.

Well, occasionally this happens accidentally, and over a remote
X connection and it takes MINUTES for the snap back animation
to complete, leaving the browser completely unresponsive in the
meantime. It is frustrating having an otherwise quite
responsive tunnelled X session clobbered by an easy to accidentally 
trigger animation whose main purpse appears to be cuteness.

Reproducible: Always
Steps to Reproduce:
1. Get two linux machines (I use Debian unstable)
2. ssh -X machineB
3. mozilla
4. highlight a word of text
5. drag it two inches, let mouse button go
6. Get coffee

Actual Results:  S_L_O_W motion animation of a document icon dragging around
while entire browser becomes unresponsive.

Expected Results:  Either a fast animation, no animation, or a responsive
browser. I'm happy with anything that doesn't hang the browser for 60 seconds.

All machines are running today's Debian Sid (unstable) but suspect this
is the case on any *nix where mozilla is tunneling though X. I'm
setting the severity to minor because I can work around (just be
super careful with the mouse) and probably not too many people
run remotely over X. I do not know if my window manager (sawfish) or
desktop environment (gnome) are affecting anything. When I run mozilla
locally on either machine, the animation takes less than a second.
(Reporter)

Comment 1

16 years ago
I'm guessing drag and drop is the correct category.
Component: XP Apps → XP Apps: Drag and Drop

Comment 2

16 years ago
I assume the latency of your connection is the problem here.
What does ping say ?
(Reporter)

Comment 3

16 years ago
>What does ping say ?

To answer this question, I need to expand the discussion to mention 3
compuers, A, B, C

A: computer at home whose screen I'm viewing (x86 linux)
B: computer in a corporate demilitarized zone (sparc solaris)
C: computer in a corporation (x86 linux)

A to B: ping reports 27 milliseconds
B to C: ping reports 0.1 milliseconds

This particular corporate LAN is pretty fast. Note that I'm really
cascading two ssh tunnels (A to B, B to C) and I don't know how much
latency ssh indueces, and I don't know how much computational
horsepower B brings to the table.

So the actual steps to reproduce (as opposed to the more simplified
initial report) are:

A: ssh -X B
B: ssh -X C
C: mozilla &

Other programs including GNU emacs 21 and KMail and most operations of
mozilla are quite usable over this two stage connection, although
there is a small but perceptable amount of sluggishness.

You know, you may be right about the latency. I just did the same
experiment here at home with just two machines a 10Mb/s local LAN
(ping time 1ms).

P: Celeron 500 desktop linux, running mozilla
Q: Pentium 133 laptop linux, displaying mozilla over ssh tunnel

Performance for the document icon animation was quite a bit better,
only jamming up the mozilla for about 5 seconds. That's within the
realm of annoying but not annoying enough to file a bug report.

Strangly, I'm seeing a slightly different animation pattern: with "A B
C", I see lots (~ten) little icons overlapping each other, with a
small translation offset of just a few pixels as per the latent mouse
tracking. With "P Q" connection, I'm still seeing the ICON following
the latent mouse path, but with much larger translations (so no
overlap) and also I'm only seeing one document icon at a time on the
screen. Not sure why this is or if it is relevent.

It still seems to me that the icon animation is an order of magnitude
performance bottleneck for running mozilla on tunnelled remote display,
and make make the difference between usable and unusable for many
real world remote connections.
Duplicate of "Too much network traffic on drag and drop ( use pointer service
instead of XQueryTree to figure out the target of DND )"

*** This bug has been marked as a duplicate of 86138 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.