launching a java applet breaks mozilla

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: grimreaperdesigns, Assigned: bae)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6) 
Gecko/20011120
BuildID:    2001112009

when I try to load my Applet in mozilla, mozilla reports to the
java console (if I had it open before I started the plugin):

java.security.AccessControlException: access denied 
(java.lang.RuntimePermission modifyThreadGroup)
	at java.security.AccessControlContext.checkPermission(Unknown Source)
	at java.security.AccessController.checkPermission(Unknown Source)
	at java.lang.SecurityManager.checkPermission(Unknown Source)
	at sun.applet.AppletSecurity.checkAccess(Unknown Source)
	at java.lang.ThreadGroup.checkAccess(Unknown Source)
	at java.lang.Thread.init(Unknown Source)
	at java.lang.Thread.<init>(Unknown Source)
	at com.stage.core.STEngine.startGame(STEngine.java:67)
	at com.stage.core.STCanvas.startGame(STCanvas.java:51)
	at com.stage.STAGEApplet.init(STAGEApplet.java:36)
	at sun.applet.AppletPanel.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

this piece of code used to work in mozilla 0.9.3, but I guess that might
be a security bug, and that I have to get some privelege, (which I can't
find information about how I do btw)...

but the fact that it doesn't work isn't the worst part, b/c when this
happens, the applet goes blank and nothing happens...
and after a short period of time mozilla starts acting wierd when I
can no longer focus the address bar and such.
Clicking the upper-right X works though, but when I do that, the following
end up in the java-console:

java.lang.NullPointerException: null pData
	at sun.awt.windows.WComponentPeer.hide(Native Method)
	at java.awt.Component.hide(Unknown Source)
	at java.awt.Window.hide(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at sun.plugin.navig.win32.PluginObject.setWindow(Unknown Source)

java.lang.NullPointerException: null pData
	at sun.awt.windows.WComponentPeer.hide(Native Method)
	at java.awt.Component.hide(Unknown Source)
	at sun.applet.AppletPanel.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

and after that the mozilla process stays "active" but unuseable and
I have to exit it from the windows taskmanager.

Reproducible: Always
Steps to Reproduce:
1. Create a new Java Applet that tries to do
<pre>
 Thread t = new Thread(this, "Whatever");
</pre>
without enabling the correct priveleges first.

2. Load the page containing the applet.

3. Try to work with mozilla.

Actual Results:  nothing works in mozilla, apart from clicking the exit-button.
mozilla process then stays "active" but unuseable and
I have to exit it from the windows taskmanager.
before I exit it from taskmanager I can't start a new instance.

Expected Results:  the error would be reported to the java-console and then 
everything would be back to normal.

Comment 1

17 years ago
->OJI
Assignee: idk → joe.chou
Component: Java-Implemented Plugins → OJI
QA Contact: avm → pmac
(Reporter)

Comment 2

17 years ago
The problem with mozilla not exiting properly seems to have nothing
to do with the threading.

Namely I can try to load an Applet which does nothing at all,
and when I try to close mozilla after that, it doesn't work.

The other wierdnesses in the interface (such as inaccessible address bar)
went away though, with the "empty" applet.
Is there a testcase available somewhere?
(Reporter)

Comment 4

17 years ago
noted that after loading the specified page, I can not do anything whatsoever 
in mozilla.
Summary: trying to start a new thread in java breaks mozilla. → launching a java applet breaks mozilla

Comment 5

17 years ago
Build ID: 2001 11 23 03. Windows 2000.

Applet loads for me, nothing happends and nothing in Java console.
Mozilla works fine afterwards.

Comment 6

17 years ago
Build ID: 2001 11 25 03. Linux. JRE 1.3.1.

Applet loads for me, nothing happends and nothing in Java console.
Mozilla works fine afterwards.

(Reporter)

Comment 7

17 years ago
Any suggestions on what could have went wrong for me then?

The installation might have failed somehow, how do I know that,
it didn't say anything about that when I installed...

Because applets used to work great in mozilla 0.9.3.

Any type of information I could send in that would help or
anything else?

Comment 8

17 years ago
Reporter, unless you can provide a test case to reproduce the problem, I can not
guess what went wrong on your machine. Otherwise, I'll mark it invalid.
(Reporter)

Comment 9

17 years ago
I guess you have to mark it as invalid then...

I have no idea on what could be wrong with it,
it might be the fact that I'm not running
explorer.exe as shell, that's the only
"strange" thing on my computer...
at least as far as I know.

Comment 10

17 years ago
Reassign to Anrew to take a look on Win2K
Assignee: joe.chou → bae
(Assignee)

Comment 11

17 years ago
I worte applet which modified their threadgroup. It works fine in Mozilla.

To reporter: 
 what version of JRE do you use?
 Could you provide the sources of the problem applet?


 
(Reporter)

Comment 12

17 years ago
As stated in a comment before, it has nothing to do with
the ThreadGroup thing.

Simply Java stopped working for me after installing 
mozilla 0.9.6.

I also noted that I sometimes get a nsLocalisedString
or something in the likes of that "couldn't be found
in xpcom.dll" or something like that... I don't know
whether it's related or not, but if it is, I can
provide a better report.

The strange thing about my system, as I mentioned
before is that I'm not running explorer.exe as shell,
but rather litestep, and I suggested that the
installation may not have been fully completed when
installing.

Another thing I came to think about right now, is
that I also have another webbrowser installed,
which uses the mozilla browser component.
I don't know if that could have any impact on anything.

As far as the source-code, the testapplet, on the
webpage supplied doesn't contain any code at all.

So something with java/mozilla0.9.6/mycomputer isn't
working as supposed to.

btw, my jre version is what I get when I run jre/java -version:
java version "1.3.0"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0-C)
Java HotSpot(TM) Client VM (build 1.3.0-C, mixed mode)

Comment 13

17 years ago
Reduced Severity to Critical.
Severity: blocker → critical

Comment 14

17 years ago
testcase URL is invalid so this cannot be reproduced. Please update the status 
(I suggest closing as invalid) so that it stops appearing on bug lists.
reporter please provide a valid URL, so someone can try to
reproduce.  
(Reporter)

Comment 16

17 years ago
Unfortunately I've lost my ability to test this.

I tried installing mozilla1.0RC1, but first the
installation failed, with a lot of messages about
routines in xpcom.dll it wasn't able to find.

When first removing the installed version, and
installing again, everything seems to be working,
apart from when I try to click any "java plugin box",
where it says "install plugin by clicking here".
When I click there the application hangs, sometimes
showing the "Install plugin" window and sometimes not.
does work here, applet loads (doing nothing).
but mozilla works fine.

tested using:
moz 1.0 RC1, windows2000, SP2
Java Plug-in 1.4.0 for Netscape Navigator (DLL Helper)
moz 1.0 RC1, Linux, SuSE 8.0 
Java(TM) Plug-in 1.3.1_02
(Reporter)

Comment 18

17 years ago
After installing mozilla1.0RC2, everythings seems to be working fine...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 19

17 years ago
This should've been WFM, not Fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 20

17 years ago
->WFM
Someone please mark this Verified.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.