[Flame][Download Manager]When we open the downloaded PDF file, the file is displayed as blank and "X" button doesn't work.

RESOLVED DUPLICATE of bug 1119157

Status

RESOLVED DUPLICATE of bug 1119157
4 years ago
4 years ago

People

(Reporter: yue.xia, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.2][Download Manager]Download a PDF file from website. After download completes, tap the PDF file from Notification bar to open it. the PDF file is displayed as blank, and the "x" button doesn't work.
See Attachment: logcat_1630.txt & Video.MP4
Found time: 16:30

[2.Testing Steps]: 
1. Launch Browser.
2. Type in the URL: http://apps.irs.gov/app/picklist/list/formsInstructions.html.
3. Search and select the PDF File to download it.
4. After download completes, tap to open it.
5. Tap the "x" button to close the PDF file.


[3.Expected Result]: 
4. The content of PDF file could be displayed ,
5. PDF file should be closed by tapping "x" button.

[4.Actual Result]: 
4. The PDF file is displayed as blank.
5. The "x" button doesn't work, we can not close the PDF file by tapping "x" button.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        69ac77cfa938fae2763ac426a80ca6e5feb6ad25
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/33781a3a5201
Build-ID        20150107010216
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]:
Free test

[8.Note]:
After kill apps via task manager, it will enter PDF screen, user have to recover it by reboot device.
(Reporter)

Comment 1

4 years ago
Created attachment 8545833 [details]
logcat
(Reporter)

Comment 2

4 years ago
Created attachment 8545869 [details]
Video
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected

Comment 3

4 years ago
Smae here, build 20150113011037
Some files work, others won't, without me knowing what could be the reason (no logic of file size, etc.)
Hi Shine, Could you help to try this on v2.1 and v2.0, thank you.
Flags: needinfo?(yue.xia)
(Reporter)

Comment 5

4 years ago
Created attachment 8554386 [details]
Flame2.0 video

Hi Eric,
This problem is verified pass on latest build of Flame2.0/2.1
1. On Flame 2.0, open the PDF file, the content can be displayed; after open PDF file, there’s no “x” button, so I can’t repro the problem of “The "x" button doesn't work”
2. On Flame 2.1, open the PDF file, the content can be displayed, tap “x” button, it can close the PDF file successfully.
See attachment: Flame2.0_video.MP4
Reproduce rate 0/10

Flame 2.0 build:
Gaia-Rev        2989f2b2bd12fcc0e9c017d2db766e76a55873b8
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/ffb9925dd084
Build-ID        20150125000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150125.033105
FW-Date         Sun Jan 25 03:31:16 EST 2015
Bootloader      L1TC000118D0

Flame 2.1 build:
Gaia-Rev        2055fc40a8bd2af1908979cb45da6b7d1c4ced0b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/38ac70ca969b
Build-ID        20150122001404
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150122.034705
FW-Date         Thu Jan 22 03:47:16 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(yue.xia)
(Reporter)

Updated

4 years ago
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
Thanks, set 2.2? for regression.
(In reply to Shine from comment #5)
> Created attachment 8554386 [details]
> Flame2.0 video
> 
> Hi Eric,
> This problem is verified pass on latest build of Flame2.0/2.1
> 1. On Flame 2.0, open the PDF file, the content can be displayed; after open
> PDF file, there’s no “x” button, so I can’t repro the problem of “The "x"
> button doesn't work”
> 2. On Flame 2.1, open the PDF file, the content can be displayed, tap “x”
> button, it can close the PDF file successfully.
> See attachment: Flame2.0_video.MP4
> Reproduce rate 0/10
> 
> Flame 2.0 build:
> Gaia-Rev        2989f2b2bd12fcc0e9c017d2db766e76a55873b8
> Gecko-Rev      
> https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/ffb9925dd084
> Build-ID        20150125000204
> Version         32.0
> Device-Name     flame
> FW-Release      4.4.2
> FW-Incremental  eng.cltbld.20150125.033105
> FW-Date         Sun Jan 25 03:31:16 EST 2015
> Bootloader      L1TC000118D0
> 
> Flame 2.1 build:
> Gaia-Rev        2055fc40a8bd2af1908979cb45da6b7d1c4ced0b
> Gecko-Rev      
> https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/38ac70ca969b
> Build-ID        20150122001404
> Version         34.0
> Device-Name     flame
> FW-Release      4.4.2
> FW-Incremental  eng.cltbld.20150122.034705
> FW-Date         Thu Jan 22 03:47:16 EST 2015
> Bootloader      L1TC000118D0
blocking-b2g: --- → 2.2?
Keywords: regression

Comment 7

4 years ago
Triage is blocking because this is a regression.
blocking-b2g: 2.2? → 2.2+
It looks like the problem is bug 1119157 that breaks JS workers some of the time (for all apps).  A fix is in progress.  Note that it's believed this problem may also reproduce on v2.1 as well.

Specifically, I have reproduced an instance of such a failure and my logcat included the expected:
02-21 12:32:27.296 W/PDF Viewer( 7919): [JavaScript Error: "InternalError: too much recursion"]

If the pdf viewer app used worker.onerror or window.onerror, those would both also fire and receive the error object.
Depends on: 1119157

Comment 9

4 years ago
Hi Cervantes, can you take a look? So this can be fixed after bug 1119157 is fixed?
Flags: needinfo?(cyu)
I also saw the same error: JavaScript Error: "InternalError: too much recursion". This should be fixed in bug 1119157.
Flags: needinfo?(cyu)

Comment 11

4 years ago
Cervantes, do you have any suggested next action plan? Thanks.
Flags: needinfo?(cyu)
If you want to confirm whether this is a duplicate of bug 1119157 then I would suggest taking the its current patch to produce a build to verify. If it is a duplicate then it will be fixed along with 1119157.
Flags: needinfo?(cyu)

Comment 13

4 years ago
Hi Cervantes, can you help to apply the patch of bug 1119157 and test this bug? The bug 1119157 is 2.2+ but this one says 2.1 unaffected? If this is dup to 1119157, this should be 2.1+ also.
Flags: needinfo?(cyu)
It looks like the same bug to me. Duplicate this bug to 1119157. We can reopen if the problem remains after 1119157 is fixed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(cyu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1119157
You need to log in before you can comment on or make changes to this bug.