If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

UITour: Hello events are not received once a second tab is opened that also uses Mozilla.UITour.observe()

RESOLVED DUPLICATE of bug 1110602

Status

()

Firefox
Tours
RESOLVED DUPLICATE of bug 1110602
3 years ago
3 years ago

People

(Reporter: agibson, Unassigned)

Tracking

37 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
STR:

1) Tour page does: Mozilla.UITour.observe((...rest) => console.log("observed", rest))
2) User opens same tour page in a new tab
3) User closes the newly opened tour page and gets switched back to #1
4) Firefox does UITour.notify(…)

Expected results:

The original tab should still receive Loop events.

Actual results:

The original tab no longer receives Loop events.

Please note that using Page Visibility API to re-register the event listener does not work in this instance.
(In reply to Alex Gibson [:agibson] from comment #0)
> Please note that using Page Visibility API to re-register the event listener
> does not work in this instance.

This bug should be fixed by the patch in bug 1110602 but I don't understand how this part can happen.
Depends on: 1110602
Alex, can you see if the quote in comment 1 is still a problem. If not, can you dupe this to bug 1110602?
Flags: needinfo?(agibson)
(Reporter)

Comment 3

3 years ago
Hi Matt - just tested and yes this seems to be fixed now. Thanks again!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(agibson)
Resolution: --- → DUPLICATE
Duplicate of bug: 1110602
You need to log in before you can comment on or make changes to this bug.