Fix a fatal warning in PossiblyFail; r=jandem

RESOLVED FIXED in mozilla37

Status

()

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

unspecified
mozilla37
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Recent clang emits the following warning (which is treated as an error) on this code:
error: implicit conversion of nullptr constant to 'bool' [-Werror,-Wnull-conversion]
Assignee: nobody → ehsan
Attachment #8545923 - Flags: review?(jdemooij)
Attachment #8545923 - Flags: review?(jdemooij) → review+
(In reply to André Bargull from comment #2)
> dup of bug 1108155?

Oh you're right. I did remember reviewing a similar patch before but thought it was another macro, but the other patch just didn't land yet...
Hm the other patch might be slightly nicer, I think we can push it for Jason if it fixes your build. Or ping him to do it.
https://hg.mozilla.org/mozilla-central/rev/bcacb5692ad9
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Sorry, I didn't see the previous comments before landing.  What should I do here?
Flags: needinfo?(jdemooij)
(In reply to :Ehsan Akhgari (not reading bugmail, needinfo? me!) from comment #6)
> Sorry, I didn't see the previous comments before landing.  What should I do
> here?

I think your patch is fine and we don't need to do anything.
Flags: needinfo?(jdemooij)
Duplicate of this bug: 1108155
Duplicate of this bug: 1086890
You need to log in before you can comment on or make changes to this bug.