Easier way to debug apps for FF desktop

RESOLVED DUPLICATE of bug 987848

Status

RESOLVED DUPLICATE of bug 987848
4 years ago
4 months ago

People

(Reporter: yajo.sk8, Unassigned)

Tracking

34 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141201111728

Steps to reproduce:

Try to debug an app in development for FF desktop.


Actual results:

WebIDE provides easy ways to debug it in Safari, Chrome, FF for Android, FFOS... But not to debug it in Firefox itself!


Expected results:

In "Select runtime" there should be an option for "Local FF for desktop", to click and debug like any other.

For workarounds and better explanation of this issue, please see http://stackoverflow.com/a/26764871/1468388

Comment 1

4 years ago
(In reply to Yajo from comment #0)
> In "Select runtime" there should be an option for "Local FF for desktop", to
> click and debug like any other.
> 
> For workarounds and better explanation of this issue, please see
> http://stackoverflow.com/a/26764871/1468388

I don't understand though, because you say you don't want Firefox OS Simulator, but you want "Desktop B2G", and then you filed this under Firefox for Desktop. In any case, I guess this is a webide bug...
Component: Untriaged → Developer Tools: WebIDE
This sounds like a dupe of bug 987848, which aims to allow WebIDE to connect apps in the desktop runtime.

Please reopen if I am mistaken.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 987848

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.